clutch problem - Team Camaro Tech
Team Camaro Tech join team camaro
 5thgen.jpg - 4890 Bytes



Registered users (free) do not see these large ads

Fifth Generation Discussion forum for the newest Camaro 2010–present


Reply
 
LinkBack Thread Tools
Display Modes
Old Jul 28th, 10, 08:33 PM   #1 (permalink)
 
Join Date: Sep 2008
Location: New York
Posts: 3
clutch problem

Hi, I am having trouble with the clutch in a 2010 Camaro in that it has a friction point about as low as it can be. If I start the car up in gear with the clutch pedal fully engaged the car wants to creep forward.

I have put a second dual diaphram clutch in for the customer and the problems is still there. The release bearing seems ok and is set to specs. Could the problem lie with the clutch master cylinder? The main resevoir is full and the pedal pressure seems normal. Does anyone know what ballpark psi is required at the throwout bearing?

Thanks,
Jmonty

Last edited by jmonty; Jul 29th, 10 at 02:43 AM. Reason: spelling error
jmonty is offline   Reply With Quote Quick reply to this message
Old Jul 28th, 10, 08:50 PM   #2 (permalink)
Senior Tech
 
Join Date: Mar 2009
Location: Lyman, SC
Posts: 8,348
Re: clutch problem

You can try bleeding the hydraulics. There is a bleeder screw down at the slave cylinder just like on a brake. Someone has to pump the clutch pedal several times and hold it while someone under the car cracks the bleeder screw. An easier way however is to use a hand vacuum pump on the bleeder nipple while someone keeps a close eye on the master cylinder since they hold so little fluid and are easy to suck dry. I think the slave is the culprit more often than the master cylinder. Got an S10 sitting in the drive right now that needs a new one.
__________________
'69 Camaro
Dart 400-AFR 195-224/224 HR-Powerjection III TB with F.A.S.T. Sportsman XFI
TKO 600-Moser 3.42-Detroit Truetrac
500hp/538lbft

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'69 Camaro Beater-SFT 327-M20-Moser 4.10-sold
'02 Z/28 vert-stock-sold and totaled
Steiner is offline   Reply With Quote Quick reply to this message
Old Jul 29th, 10, 10:54 AM   #3 (permalink)
Senior Tech
 
67 Convertible's Avatar
 
Join Date: Oct 2004
Location: Hudson, MA
Posts: 1,501
Re: clutch problem

Try the camaro5 forum www.camaro5.com
Lots of good info and knowledge about the 2010's.
__________________
'67 Marina Blue Convertible. L30, PG. All numbers match, 41k original miles.

"The only time you have too much fuel, is when you're on fire"
67 Convertible is offline   Reply With Quote Quick reply to this message
Old Jul 30th, 10, 02:38 AM   #4 (permalink)
 
Join Date: Sep 2008
Location: New York
Posts: 3
Re: clutch problem

Thanks to both you and Steiner for the replies. I think I found the problem in that the throwout bearing is now almost 1/2" too short as the Ram flywheel and clutch assembly is that much thinner. I found out through your suggestion to go to Camaro5.com that LPE sells an adapter/spacer that should solve the problem.

Thanks again, John Montelione
jmonty is offline   Reply With Quote Quick reply to this message
Reply
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:
Location
Location
First Name
Rather than just Hot69, gotta real name?

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Recent Discussions
67 Hood Vents - Engine...
Feb 7th, 20 01:48 PM
Last post by Milt's 68 SS/RS 396
Today 08:37 PM
41 Replies, 1,890 Views
My 67 Resto Mod Build
Jul 29th, 18 05:58 PM
by Sosh67
Last post by Sosh67
Today 08:21 PM
292 Replies, 25,778 Views
Power steering hoses
Today 07:23 PM
by mpeters
Last post by Riverbud
Today 08:03 PM
1 Replies, 23 Views
clutch pushrod bushings
Mar 30th, 20 09:04 PM
Last post by Luwi67
Today 07:28 PM
1 Replies, 71 Views
1968 Gauge Cluster...
Mar 30th, 20 10:47 AM
Last post by jcabuilder
Today 07:24 PM
12 Replies, 304 Views
1969 Console rear ashtray
Today 01:52 PM
by TonyS
Last post by TonyS
Today 07:12 PM
3 Replies, 73 Views
Rear Wiring Harness...
Today 07:00 PM
by JugBolt
Last post by JugBolt
Today 07:00 PM
0 Replies, 15 Views
Getting the correct bell...
Mar 30th, 20 06:59 PM
Last post by dyno jonn
Today 06:33 PM
3 Replies, 141 Views
Humpday Humor, 4/1 ......
Today 03:53 AM
Last post by 69Z28
Today 06:23 PM
7 Replies, 136 Views
Tailight hardware...
Today 02:45 PM
Last post by stamatisg1977
Today 05:58 PM
3 Replies, 66 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 08:44 PM.



Camaros.net - © 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.