LS1 hooker mounts issue - Team Camaro Tech
Pro Touring Todays performance with classic style

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old Jun 23rd, 13, 02:57 PM Thread Starter
Senior Tech
 
Join Date: Mar 2005
Location: Phoenix, AZ.
Posts: 100
Question LS1 hooker mounts issue

I know i have read on here quite often that the hooker swap mounts put the engine close to the firewall but GEEZ! I finally got it installed and im not too thrilled about how CLOSE it puts the engine to it, I mean were talking about fingernail thickness close (pass side). So i get researching and find that hooker now makes mounts with different increments moving the engine forward. I am wondering if anyone has used these different mounts and if so has any pics before I have to purchase different ones. Thanks for any help.
badazzbowties is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old Jun 23rd, 13, 03:07 PM
Senior Tech
Bob
 
Join Date: Oct 2007
Location: Holly Springs, GA
Posts: 1,354
Re: ls1 hooker mounts issue

I bought the Hooker "stock location" mounts and knew there was an issue before I even installed the engine. I measured from the mount to the back of the block and found that the bellhousing would be kissing the firewall, so I went with the "1 1/4 setback mounts instead and now have plenty of room. My BMR crossmember also wouldn't have worked with the stock location mounts, since its pretty much all the way back even with these mounts.
BobKovacs is offline  
post #3 of 8 (permalink) Old Jun 23rd, 13, 06:55 PM Thread Starter
Senior Tech
 
Join Date: Mar 2005
Location: Phoenix, AZ.
Posts: 100
Re: ls1 hooker mounts issue

Those are the ones I am looking at now, I have the t56 hurst conversion tranny xmember so i think it will be fine with the other mounts just stinks to have to buy another set of mounts you know?!? thanks for the info!
badazzbowties is offline  
 
post #4 of 8 (permalink) Old Jun 23rd, 13, 06:59 PM Thread Starter
Senior Tech
 
Join Date: Mar 2005
Location: Phoenix, AZ.
Posts: 100
Re: ls1 hooker mounts issue

Are you using hooker headers as well?
badazzbowties is offline  
post #5 of 8 (permalink) Old Jun 24th, 13, 03:12 AM
Senior Tech
Bob
 
Join Date: Oct 2007
Location: Holly Springs, GA
Posts: 1,354
Re: ls1 hooker mounts issue

No- I used a set of stainless shorty headers from ProComp.
BobKovacs is offline  
post #6 of 8 (permalink) Old Jun 24th, 13, 04:01 AM
Senior Tech
chuck
 
chucky 67's Avatar
 
Join Date: Jul 2008
Location: San Diego
Posts: 164
Re: ls1 hooker mounts issue

Dingo Adjustable mounts work. http://dirtydingo.com/store/product_...oducts_id=1372

1967 camaro LS3 TKO 5 speed A.C. delux Int.
chucky 67 is offline  
post #7 of 8 (permalink) Old Jun 24th, 13, 10:17 AM
Gold Lifetime Member
Brent
 
67Rally's Avatar
 
Join Date: Feb 2010
Location: Boston, MA
Posts: 4,805
Garage
Re: ls1 hooker mounts issue

Quote:
Originally Posted by chucky 67 View Post
I just used these on my LS swap. They are very nice and have a ton of adjustability. You are really only limited by where the headers want to fall in relation to the PS box.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
67Rally is offline  
post #8 of 8 (permalink) Old Jul 14th, 13, 03:21 PM
 
Join Date: Jun 2013
Location: Ocala, FL
Posts: 6
Re: LS1 hooker mounts issue

I'm currently fitting an ls1 into my 69 Camaro. The car came with Trans Dapt plates and I felt the engine was sitting too far forward. Hooker long tube headers were way too close to the steering gear box.

I had a guy locally make a set that moved the engine back closer to the firewall. Now the headers clear perfectly, but the bell housing seems to be hitting the floor. (4L60 trans)

I'm taking a break for the weekend because I'm frustrated. What are you guys that set the engine really close to the firewall doing? Cutting the tunnel so the trans fits?
ls1camaro69 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome