ls swap 68 camaro pulley problem - Team Camaro Tech
Pro Touring Todays performance with classic style

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Aug 10th, 13, 06:37 PM Thread Starter
Senior Tech
 
Join Date: Mar 2005
Location: Phoenix, AZ.
Posts: 100
ls swap 68 camaro pulley problem

Not sure if this is the right place to post this but here goes, im putting a 04 vette ls1 into my 68 camaro and found after I got the motor in and put the acc bracket on for the alt and ps
pump on that the ps pulley is extremely close to the front bolt for the upper control arm. has anyone seen this because I though the vette acc were the ones you could run with no problems, or is the pulley on the f-body LS smaller so maybe i can swap pulleys or something, any info would be great thanks!
badazzbowties is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Aug 11th, 13, 08:06 AM Thread Starter
Senior Tech
 
Join Date: Mar 2005
Location: Phoenix, AZ.
Posts: 100
Re: ls swap 68 camaro pulley problem

Nevermind answered my own question sorry! dont know why I dont forum search before posting a topic haha.
badazzbowties is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome