Speedometer Trouble - Team Camaro Tech
Team Camaro Tech join team camaro
 Ground Up Restorations

Official Sponsor of Team Camaro



Registered users (free) do not see these large ads

Second Generation 1970-1981


Reply
 
LinkBack Thread Tools
Display Modes
Old Sep 13th, 14, 08:38 PM   #1 (permalink)
Probationer
 
Dicky's Avatar
 
Join Date: Jan 2009
Location: KCYS
Posts: 4
Speedometer Trouble

I have a speedometer that has a jumpy needle from 0-40 MPH.
After that it is smooth. Do you guys think it would be the cable causing this or the speedo that is making it jump?

Thanks in advance, Dicky
__________________
Dicky
Dicky is offline   Reply With Quote Quick reply to this message
Old Sep 13th, 14, 10:05 PM   #2 (permalink)
Admin/Super Moderator
 
69-Pace's Avatar
 
Join Date: Jun 2010
Location: Connecticut USA
Posts: 12,511
Garage
Re: Speedometer Trouble

could be either. Dry cable does this a lot of the time.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Z11 Pace Car - L48 350cid/300hp - 4 Speed Muncie 12 bolt rear.

Super Moderator Team Camaro
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
to send me a private message
69-Pace is offline   Reply With Quote Quick reply to this message
Old Sep 13th, 14, 11:01 PM   #3 (permalink)
Senior Tech
 
Join Date: Dec 2005
Location: New Zealand
Posts: 13,324
Send a message via ICQ to Steptoe
Re: Speedometer Trouble

Run a forum search...
for how to clean out and re grease the cable and u will find other possible issues such as the clip for the drive cog inside the tail shaft circlip being loose or coming off
__________________
My Spelling is not incorrect...it is creative

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Steptoe is offline   Reply With Quote Quick reply to this message
Old Sep 14th, 14, 08:07 PM   #4 (permalink)
Probationer
 
Dicky's Avatar
 
Join Date: Jan 2009
Location: KCYS
Posts: 4
Re: Speedometer Trouble

Well I've lubed the cable with no positive results, so now
I will look at my other options. Speedo calibration comes to mind.

Thanks D.
__________________
Dicky
Dicky is offline   Reply With Quote Quick reply to this message
Old Sep 16th, 14, 02:53 PM   #5 (permalink)
Senior Tech
 
Join Date: Dec 2005
Location: New Zealand
Posts: 13,324
Send a message via ICQ to Steptoe
Re: Speedometer Trouble

speedo calibration .. very unlikely because they are simple cog ratios
the gear drive in the tail shaft, check both the driver and driven cogs and circlips
and be 100% sure u have the end of the inner cable correctly set in the back of the speedo and bottom end.
__________________
My Spelling is not incorrect...it is creative

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Steptoe is offline   Reply With Quote Quick reply to this message
Reply
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Recent Discussions
67 RS Headlights Doors...
May 31st, 20 07:37 PM
Last post by bob15
Today 03:29 PM
5 Replies, 184 Views
Attention 1st gen Big...
Today 01:39 PM
by LYK2ROC
Last post by Matt 69
Today 02:56 PM
2 Replies, 47 Views
Coolant overflow dumping...
Jun 2nd, 20 08:43 PM
Last post by Lonnie P
Today 02:14 PM
17 Replies, 428 Views
Insurance Agreed Value
May 30th, 20 08:22 PM
Last post by SoCal805
Today 01:59 PM
26 Replies, 1,026 Views
picture link test
Yesterday 05:46 PM
by jimsl78
Last post by Garfields Maro
Today 01:57 PM
11 Replies, 185 Views
i have a points...
Yesterday 10:45 AM
Last post by SoCal805
Today 01:40 PM
7 Replies, 198 Views
First time Camaro owner
Today 08:40 AM
by ForFun
Last post by Everett#2390
Today 01:10 PM
4 Replies, 81 Views
Affordable options to...
May 2nd, 20 09:40 AM
Last post by crazyshopmonkey
Today 12:21 PM
8 Replies, 353 Views
YA coded N66 SS style...
Jun 2nd, 20 11:30 AM
Last post by RSSSfanatic
Today 11:59 AM
7 Replies, 230 Views
Gap between door and...
Jun 2nd, 20 07:44 AM
by bthomas
Last post by Garfields Maro
Today 10:38 AM
7 Replies, 287 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 03:31 PM.



Camaros.net - 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.