1970 Camaro RS 307 - Team Camaro Tech
Team Camaro Tech join team camaro
 Ground Up Restorations

Official Sponsor of Team Camaro



Registered users (free) do not see these large ads

Second Generation 1970-1981


Reply
 
LinkBack Thread Tools
Display Modes
Old Jul 15th, 17, 05:29 PM   #1 (permalink)
Probationer
 
Join Date: Jul 2017
Location: VIRGINIA
Posts: 1
1970 Camaro RS 307

Car hasn't been started in many years, has new battery, cap, rotor, plugs, wires, & coil. Motor turns over but will not spark. Took a jumper wire from the battery to the positive side of the coil and still not getting any spark. Someone help
ProjectRS1970 is offline   Reply With Quote Quick reply to this message
Old Jul 15th, 17, 06:59 PM   #2 (permalink)
Gold Lifetime Member
 
Join Date: Jan 2013
Location: Mobile AL
Posts: 1,671
Re: 1970 Camaro RS 307

My guess is bad coil..
__________________
Tony
Follow my current Camaro project builds...
1967 Coupe (Sold)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1968 Convertible

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Convertible
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bondora68 is offline   Reply With Quote Quick reply to this message
Old Jul 16th, 17, 07:13 AM   #3 (permalink)
Super Moderator
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 32,177
Garage
Re: 1970 Camaro RS 307

Or point set is not opening up as in a worn rubbing block.
Or, bad ground on dist body to block.
__________________
Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is online now   Reply With Quote Quick reply to this message
Old Jul 16th, 17, 09:10 AM   #4 (permalink)
Senior Tech
 
Join Date: Jun 2007
Location: Iowa
Posts: 3,888
Re: 1970 Camaro RS 307

If you're still running the original points ignition change the points and condenser.
If electronic ignition I would suspect a bad module. In either case make sure
the rotor top contact tab is contacting the cap center pole. You may also
have a blown resistor wire feeding the points. I think the resistor wire was
still used in 70.
__________________
Al

my 67' build thread:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
allanjs is offline   Reply With Quote Quick reply to this message
Reply
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:
Location
Location
First Name
Rather than just Hot69, gotta real name?

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Recent Discussions
Loony Libs & Dim Dems in...
Jan 24th, 19 01:40 PM
Last post by dhutton
Today 05:32 AM
1 Replies, 11,421 Views
69 manual window...
May 28th, 20 05:27 AM
Last post by Skates_236
Today 05:26 AM
13 Replies, 210 Views
New paint care
Yesterday 07:57 AM
Last post by dhutton
Today 05:01 AM
14 Replies, 253 Views
383 refresh
Yesterday 07:55 AM
Last post by DOUG G
Today 04:47 AM
8 Replies, 205 Views
Should I put a 160...
May 17th, 20 12:09 PM
Last post by 69ss350
Today 04:37 AM
23 Replies, 792 Views
Interior redo in only 21...
Yesterday 08:49 PM
by patman2
Last post by Andrew69
Today 04:37 AM
1 Replies, 83 Views
just a picture
May 26th, 20 09:01 AM
Last post by rgwiz
Today 04:34 AM
15 Replies, 427 Views
Humpday Humor, 5/27 ......
May 27th, 20 03:11 AM
Last post by adjudimo
Today 04:25 AM
2 Replies, 204 Views
Irs $$$$
May 26th, 20 07:03 PM
by DOUG G
Last post by adjudimo
Today 04:17 AM
14 Replies, 470 Views
memorial day
May 23rd, 20 04:49 AM
Last post by adjudimo
Today 04:01 AM
18 Replies, 507 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 05:37 AM.



Camaros.net - 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.