Windshield wiper arms....they suck... - Team Camaro Tech
Team Camaro Tech join team camaro
  



Registered users (free) do not see these large ads

Fourth Generation 1993-2002


Reply
 
LinkBack Thread Tools
Display Modes
Old Feb 21st, 07, 07:05 PM   #1 (permalink)
 
Join Date: Feb 2007
Posts: 6
Exclamation Windshield wiper arms....they suck...

Why is it that they were made upside down??? The stupid "J" hook that you attach the wiper blades onto is upside down, making my wiper blades leave gaps on the windshield when they are used....is there ANY way around this problem???
CajunCamRS06 is offline   Reply With Quote Quick reply to this message
Old Feb 21st, 07, 08:28 PM   #2 (permalink)
Senior Tech
 
ZZ_430's Avatar
 
Join Date: May 2001
Location: Houston, Texas
Posts: 4,491
Re: Windshield wiper arms....they suck...

Spray the windshield with foam glass cleaner so you can see the contact pattern.

Turn the wipers on, and then use the ignition key to stop them mid-arc. You will see an obvious gap where the blades don't touch the glass.

Carefully bend the metal part of the arm to get full contact against the glass. Of course you want to be careful and not break the part of the arm that is plastic.

Then again check your work using the foam glass cleaner.
__________________
Don ~ TC Member #15 ~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Don't mess with Texas!
ZZ_430 is offline   Reply With Quote Quick reply to this message
Old Feb 22nd, 07, 06:05 PM   #3 (permalink)
 
Join Date: Jan 2007
Posts: 1,163
Re: Windshield wiper arms....they suck...

another problem is rust in the pivot point...wd40 at the pivot and the above post will probably get you going...
kustomwerker is offline   Reply With Quote Quick reply to this message
Old Oct 5th, 07, 03:43 PM   #4 (permalink)
 
Join Date: Oct 2007
Posts: 2
Re: Windshield wiper arms....they suck...

I have the exact same problem on a 1995 camaro. The driver's side wiper does not fully contact the windshield throughout the entire sweep. It's SO frustrating. I've ordered a replacement wiper arm hoping that will fix it, but now after reading this I have my doubts. But.....what is the problem? You shouldn't have to go bending brand new wiper blades in order to make them contact the windshield. That's just a bandaid. What is the fix?
mdunn is offline   Reply With Quote Quick reply to this message
Reply
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:
Location
Location
First Name
Rather than just Hot69, gotta real name?

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wiper Arms Barry H Body Shop 2 Oct 24th, 05 09:16 AM
Windshield Wiper Pressure Seakane Camaro Tech 13 Jun 13th, 05 11:04 AM
windshield wiper motor does not work hobackriver Electrical & Wiring 5 Jul 17th, 03 04:52 AM
Calling all wiper arms! coach420 Body Shop 17 Jun 19th, 02 07:00 AM
windshield wiper help 68SS396 Tech 2000 2 Jun 23rd, 00 10:06 AM

» Recent Discussions
Overheating Concerns '67...
Sep 5th, 19 12:34 PM
Last post by 69-er
Today 09:06 AM
35 Replies, 810 Views
carb tuning with...
Sep 16th, 19 08:47 AM
Last post by bhodgdon400
Today 09:03 AM
23 Replies, 340 Views
Rear Rub when turning
Today 08:55 AM
Last post by JakeSpoon
Today 08:55 AM
0 Replies, 11 Views
15 inch rally wheel trim...
Sep 8th, 19 12:35 PM
Last post by BOOGIES
Today 08:40 AM
11 Replies, 275 Views
Replacing pinion seal &...
Jul 17th, 05 07:12 AM
Last post by Niblet
Today 08:24 AM
12 Replies, 16,241 Views
bucket seat lock latch...
Today 07:26 AM
Last post by aircavalryveteran
Today 07:26 AM
0 Replies, 23 Views
Shock from horn
Aug 22nd, 19 06:59 AM
Last post by bondora68
Today 06:39 AM
18 Replies, 559 Views
Door Glass Doesn't Match...
Sep 14th, 19 05:48 AM
Last post by The Camaro Guy
Today 05:44 AM
12 Replies, 338 Views
Hello from Chicago
Yesterday 08:14 AM
Last post by Andrew69
Today 05:32 AM
3 Replies, 77 Views
Fuel line routing issue...
Sep 9th, 19 05:36 AM
by HawkX66
Last post by HawkX66
Today 04:37 AM
15 Replies, 376 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 09:10 AM.



Camaros.net - 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.