Need heater help please - Team Camaro Tech
Team Camaro Tech join team camaro
  



Registered users (free) do not see these large ads

Fourth Generation 1993-2002


Reply
 
LinkBack Thread Tools
Display Modes
Old Nov 25th, 07, 02:23 PM   #1 (permalink)
 
Join Date: Nov 2007
Posts: 2
Need heater help please

Hey guys i just got a 93 Camaro and when i turn the heater fan up it hums like the air is vibrating on something, and there is no air going to the top vents. The defrost gets a little air, but not much. i feel really hot air coming from under the glove box. does anyone know what i should do to get the heater to stop humming and how to get the air going to the top vents? any help is much appreciated. thanks!
theleprechaun07 is offline   Reply With Quote Quick reply to this message
Old Nov 25th, 07, 02:43 PM   #2 (permalink)
 
Join Date: Nov 2007
Posts: 2
Re: Need heater help please

Insufficient, Erratic, or No Heat

low coolant level
incorrect thermostat
restricted coolant flow through core
heater hoses plugged
misadjusted control cable
sticking heater control valve
vacuum hose leaking
vacuum hose blocked
cavvum motors inoperative
blocked air inlet
inoperative heater blower motor
oil residue on heater core fins
dirt on heater core fins

air from defroster at all times

vacuum system leak
improperly adjusted control cables
inoperative vacuum motor

blower does not operate correctly

blown fuse
blower motor windings open
reistors burned out
motor ground conections loose
wiring harness connections loose
blower motor switch inoperative
fan binding or foriegn object in housing
fan blades bent or broken
Sloppsta is offline   Reply With Quote Quick reply to this message
Old Nov 26th, 07, 12:47 PM   #3 (permalink)
 
Join Date: Nov 2007
Posts: 2
Re: Need heater help please

thanks
theleprechaun07 is offline   Reply With Quote Quick reply to this message
Old Dec 21st, 07, 10:19 AM   #4 (permalink)
 
Join Date: Aug 2007
Posts: 97
Re: Need heater help please

Now that is detailed info!! One more thing. I had the same humming sound when I would turn on my heater and I would get very little air if I turned the switch to blow thru my top vents. The seals and/or insulation by my heater core were coroded so I bought some rubber foam from the local hardware store and replace the insulation. I used black duct tape for the out side and it stopped the humming completely and the air blows better than it ever did. Hope this helped.
LT1RUNNER is offline   Reply With Quote Quick reply to this message
Old Dec 23rd, 07, 05:09 PM   #5 (permalink)
Senior Tech
 
Join Date: Mar 2002
Location: Austin, TX, USA
Posts: 5,277
Re: Need heater help please

If the blower cage gets out of balance it'll roar and vibrate like crazy. Usually leaves are the culprit. Now days, the blower motor is often installed pointing stright up above the passengers floor pan and held in place by 3 screws. Drop it down and see what is stuck inside the blower cage.
__________________
Dave
========================
68 Coupe, 350 w/ Edelbrock Performer RPM heads, cam, intake, 700R4, Dave's small body HEI
dnult is offline   Reply With Quote Quick reply to this message
Reply
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:
Location
Location
First Name
Rather than just Hot69, gotta real name?

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Recent Discussions
Took home my 2nd Best in...
Yesterday 06:37 AM
Last post by BlueRibbon
Today 09:38 AM
10 Replies, 184 Views
Camaro specialties
Dec 19th, 10 06:14 AM
by perky
Last post by adjudimo
Today 09:35 AM
43 Replies, 14,019 Views
Overheating Concerns '67...
Sep 5th, 19 12:34 PM
Last post by allanjs
Today 09:20 AM
33 Replies, 751 Views
Coil Bracket
Today 03:34 AM
Last post by Z282NV
Today 09:16 AM
4 Replies, 81 Views
true car weight
Today 06:56 AM
Last post by allanjs
Today 09:15 AM
5 Replies, 68 Views
Mid-pipes
Today 04:26 AM
Last post by bruce69camaro
Today 08:52 AM
4 Replies, 76 Views
Hello from Chicago
Today 08:14 AM
Last post by thedocs2
Today 08:14 AM
0 Replies, 19 Views
carb tuning with...
Yesterday 08:47 AM
Last post by bhodgdon400
Today 06:35 AM
15 Replies, 209 Views
Single leaf springs to...
Sep 15th, 19 07:33 AM
Last post by thedocs2
Today 06:35 AM
9 Replies, 242 Views
Shock from horn
Aug 22nd, 19 06:59 AM
Last post by bondora68
Today 06:30 AM
16 Replies, 494 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 09:40 AM.



Camaros.net - 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.