engine power loss - Team Camaro Tech
Team Camaro Tech join team camaro
  



Registered users (free) do not see these large ads

Fourth Generation 1993-2002


Reply
 
LinkBack Thread Tools
Display Modes
Old Dec 20th, 07, 10:24 AM   #1 (permalink)
 
Join Date: Dec 2007
Posts: 2
engine power loss

I have a 2000 camaro V6 . I have a error message"reduced engine power" when the light comes on the car loses power and will only perform at idle speed.
I diagnosed the codes of P1221,P1516. Which has something to do with the throttle position. Any suggestions? I'm wondering if it is the throttle sensor on throttle body or the sensor on the gas pedal.
bear61255 is offline   Reply With Quote Quick reply to this message
Old Dec 20th, 07, 03:59 PM   #2 (permalink)
 
Join Date: Dec 2007
Posts: 39
Re: engine power loss

I would replace the tps.
CamaroBrandon is offline   Reply With Quote Quick reply to this message
Old Dec 21st, 07, 05:29 AM   #3 (permalink)
Senior Tech
 
Join Date: Mar 2002
Location: Austin, TX, USA
Posts: 5,277
Re: engine power loss

Didn't know there was a sensor on the pedal. My guess would be the TPS on the throttle body. You should be able to disconnect it and measure resistance between the center and an outer terminal. Then move the throttle smoothly through it's range of motion looking for a smooth change in resistance. The high-use spots are where the problems show up. Usually that is just above idle.
__________________
Dave
========================
68 Coupe, 350 w/ Edelbrock Performer RPM heads, cam, intake, 700R4, Dave's small body HEI
dnult is offline   Reply With Quote Quick reply to this message
Old Dec 21st, 07, 08:45 AM   #4 (permalink)
 
Join Date: Dec 2007
Posts: 2
Re: engine power loss

Thanks guys, will give that a try...
bear61255 is offline   Reply With Quote Quick reply to this message
Old Dec 21st, 07, 08:51 AM   #5 (permalink)
Gold Lifetime Member
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: engine power loss

Does the 2000 v6 have a drive by wire throttle?
If it does, that's the problem.



__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline   Reply With Quote Quick reply to this message
Reply
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:
Location
Location
First Name
Rather than just Hot69, gotta real name?

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Recent Discussions
Alternator Wisdom?
Today 01:49 PM
Last post by really_n0b0dy
Today 01:49 PM
0 Replies, 13 Views
Original 67 SS350 engine...
Sep 12th, 19 04:30 PM
by stryqer
Last post by Niblet
Today 01:31 PM
7 Replies, 332 Views
1991 camaro horn switch
Sep 14th, 19 04:27 PM
Last post by BRICO69
Today 01:23 PM
2 Replies, 99 Views
bucket seat lock latch...
Today 07:26 AM
Last post by allanjs
Today 12:56 PM
1 Replies, 45 Views
Replacing pinion seal &...
Jul 17th, 05 07:12 AM
Last post by big gear head
Today 12:49 PM
17 Replies, 16,311 Views
carb tuning with...
Sep 16th, 19 08:47 AM
Last post by HawkX66
Today 12:21 PM
25 Replies, 384 Views
How to upload pic of my...
Today 10:56 AM
Last post by dhutton
Today 12:03 PM
2 Replies, 50 Views
Rear Rub when turning
Today 08:55 AM
Last post by DjD
Today 09:24 AM
1 Replies, 67 Views
Overheating Concerns '67...
Sep 5th, 19 12:34 PM
Last post by 69-er
Today 09:06 AM
35 Replies, 834 Views
15 inch rally wheel trim...
Sep 8th, 19 12:35 PM
Last post by BOOGIES
Today 08:40 AM
11 Replies, 288 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 03:26 PM.



Camaros.net - 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.