only 16 MPG?! 3.4L v6 - Team Camaro Tech
Team Camaro Tech join team camaro
  



Registered users (free) do not see these large ads

Fourth Generation 1993-2002


Reply
 
LinkBack Thread Tools
Display Modes
Old Jul 14th, 09, 02:23 PM   #1 (permalink)
 
Join Date: Jul 2009
Posts: 18
Unhappy only 16 MPG?! 3.4L v6

my 95 3.4L seems to run pretty good
but im only getting 16 MPG and i dont
hot rod it, i mostly cruise at less than
2000 PRM and rarely get on it at all.
are there possibly any sensors/etc that i should
change to improve my mileage?
any other suggestions? ...zimmy
zimmyjim is offline   Reply With Quote Quick reply to this message
Old Jul 14th, 09, 07:41 PM   #2 (permalink)
Senior Tech
 
Join Date: May 2009
Location: East Coast
Posts: 247
Re: only 16 MPG?! 3.4L v6

How many miles is on it? Friend of mine had same prob and had a clogged cat and replaced 02 sensors and straightened it out. Also try cleaning air filter. It's not breathing like it's suppose to.
BadMrFrossty is offline   Reply With Quote Quick reply to this message
Old Jul 14th, 09, 09:13 PM   #3 (permalink)
 
Join Date: Jul 2009
Posts: 18
Re: only 16 MPG?! 3.4L v6

it has almost 118000 on it.....
the air filter is clean.
replacing the 02 sensors seems like
a good idea....i want to replace "all"
of the sensors on the motor, but im
a little broke right now so im tring to
prioritize till i get some cash .....z
zimmyjim is offline   Reply With Quote Quick reply to this message
Old Jul 15th, 09, 03:54 AM   #4 (permalink)
Gold Lifetime Member
 
SPARKY69's Avatar
 
Join Date: Oct 2007
Location: HENDERSONVILLE N.C.
Posts: 9,352
Re: only 16 MPG?! 3.4L v6

Plugs????????
SPARKY69 is offline   Reply With Quote Quick reply to this message
Old Jul 15th, 09, 10:30 AM   #5 (permalink)
 
Join Date: Jul 2009
Posts: 18
Re: only 16 MPG?! 3.4L v6

i just got it a couple weeks ago and i believe
the plugs and wires are new already ....z
zimmyjim is offline   Reply With Quote Quick reply to this message
Old Jul 15th, 09, 02:28 PM   #6 (permalink)
Senior Tech
 
Join Date: Dec 2005
Location: Massachusetts
Posts: 1,391
Garage
Re: only 16 MPG?! 3.4L v6

Wow, 16 mpg is terrible for a six. I like the O2 sensor and catalytic converter replacement idea. If your state has vehicle emissions, you might have them hook the car up and do a read out and see if everything is good. ...... Oh, btw, you could try disconnecting the battery for a while, then hooking it back up. This should cause the computer to relearn everything and it 'might' run better.
arocars is offline   Reply With Quote Quick reply to this message
Old Jul 19th, 09, 05:24 PM   #7 (permalink)
 
Join Date: Jul 2009
Posts: 18
Re: only 16 MPG?! 3.4L v6

i changed the 02 sensors yesterday...seemed to run a little better till today when it decided not to start. z
zimmyjim is offline   Reply With Quote Quick reply to this message
Old Jul 20th, 09, 04:34 PM   #8 (permalink)
Senior Tech
 
Join Date: Apr 2007
Location: iowa
Posts: 201
Re: only 16 MPG?! 3.4L v6

leaking fuel pressure regulator?
__________________
NEVER argue with a stupid person. They bring you down to their level, and then beat you with experience.
bighaas79 is offline   Reply With Quote Quick reply to this message
Old Nov 13th, 09, 07:49 PM   #9 (permalink)
 
Join Date: Nov 2009
Posts: 8
Re: only 16 MPG?! 3.4L v6

Id be happy with 16. but i got an auto with 2nd and 4th gone out of it. So, i get about 10mpg. Check the cat
750chop is offline   Reply With Quote Quick reply to this message
Reply

Tags
3.4l, mileage
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:
Location
Location
First Name
Rather than just Hot69, gotta real name?

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Recent Discussions
Old Movies with Camaros
Yesterday 07:42 AM
Last post by hotrodbaker
Today 12:32 AM
9 Replies, 204 Views
Humpday Humor, 4/1 ......
Apr 1st, 20 03:53 AM
Last post by adjudimo
Yesterday 11:40 PM
11 Replies, 237 Views
On a lighter note...
Apr 2nd, 20 08:43 PM
by 69Z28
Last post by adjudimo
Yesterday 11:16 PM
5 Replies, 165 Views
'67 396
Yesterday 03:11 PM
Last post by adjudimo
Yesterday 11:01 PM
7 Replies, 142 Views
Niblet Changes his...
Mar 10th, 20 05:10 PM
by Niblet
Last post by Niblet
Yesterday 09:56 PM
16 Replies, 522 Views
A little brake and...
Yesterday 09:16 PM
Last post by bill3337
Yesterday 09:16 PM
0 Replies, 25 Views
upper control arm...
Yesterday 02:10 PM
Last post by allanjs
Yesterday 09:10 PM
4 Replies, 76 Views
Brakes won’t...
Apr 4th, 20 04:28 PM
by Tdog
Last post by r_w
Yesterday 09:09 PM
12 Replies, 191 Views
Just joining!
Apr 3rd, 20 06:58 PM
Last post by ajviper
Yesterday 09:04 PM
11 Replies, 168 Views
69 Camaro Turbo EFI 250
Yesterday 08:26 PM
Yesterday 08:28 PM
1 Replies, 45 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 12:50 AM.



Camaros.net - 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.