95 camaro LT1 Problems - Team Camaro Tech
Team Camaro Tech join team camaro
  



Registered users (free) do not see these large ads

Fourth Generation 1993-2002


Reply
 
LinkBack Thread Tools
Display Modes
Old Mar 16th, 10, 02:16 PM   #1 (permalink)
 
Join Date: Jan 2009
Location: Allen, texas
Posts: 15
95 camaro LT1 Problems

I have a 95 camaro(LT1), and I'm getting a ticking sound(usually off cold start) while accelerating between about 1500-3000 rpm is when you can hear it. Sometimes I also get a sputtering sound with this tick. It usually quiets down or completely goes away when my car warms up, but sometimes it does not. At times also feels like I have a loss of power when this happens.

I also have a problem with oil pressure. Off a cold start it sits really high(usually between 60-70) and if I don't let it warm up it gets dangerously high like near 80.

Was just wondering if anyone had a few ideas as to what it may be(mainly the ticking).

Thanks,

Tyler Murray.
TyMurray95z28 is offline   Reply With Quote Quick reply to this message
Old May 3rd, 10, 11:02 PM   #2 (permalink)
Senior Tech
 
Join Date: May 2000
Location: Galt,CA,USA
Posts: 306
Re: 95 camaro LT1 Problems

I have the same ticking on mine when it's cold. It's an exhust leak on the right side on my car. It may feel like you are down on power because the car is still cold and maybe hesitating a bit.
__________________
- John -

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
X77D80 is offline   Reply With Quote Quick reply to this message
Reply

Tags
lt1, sputter, tick
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:
Location
Location
First Name
Rather than just Hot69, gotta real name?

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Recent Discussions
Paint first or Motor...
Yesterday 04:43 PM
by AZ_Bill
Last post by HawkX66
Today 07:36 AM
6 Replies, 128 Views
What suspension kit for...
Yesterday 07:46 AM
by majj35
Last post by majj35
Today 07:30 AM
14 Replies, 189 Views
Original Spark Plugs for...
Today 07:29 AM
by Niblet
Last post by Niblet
Today 07:29 AM
0 Replies, 8 Views
Help! Weird noise near...
Yesterday 09:20 AM
by majj35
Last post by majj35
Today 07:29 AM
6 Replies, 138 Views
Distributor rebuild and...
Yesterday 11:45 AM
by CDB
Last post by Niblet
Today 07:25 AM
7 Replies, 166 Views
1969 Camaro...
Oct 18th, 19 03:02 PM
by BadCo69
Last post by railbrd9
Today 07:03 AM
23 Replies, 541 Views
Power window issue
Yesterday 07:56 PM
Last post by Everett#2390
Today 06:40 AM
1 Replies, 52 Views
MAP, MAT, MAP Vac
Today 05:41 AM
Last post by Sixty8Camaro
Today 06:30 AM
3 Replies, 48 Views
68 Camaro RS, Rear Diff...
Oct 19th, 19 06:38 PM
Last post by Everett#2390
Today 06:19 AM
5 Replies, 135 Views
69 rustbucket rebirth
Jul 22nd, 13 11:38 AM
Last post by tp_smith
Today 05:32 AM
1 Replies, 188,206 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 07:52 AM.



Camaros.net - © 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.