power steering problem part 2 - Team Camaro Tech
Team Camaro Tech join team camaro
  



Registered users (free) do not see these large ads

Fourth Generation 1993-2002


Reply
 
LinkBack Thread Tools
Display Modes
Old Aug 2nd, 10, 07:56 AM   #1 (permalink)
 
Join Date: Dec 2003
Location: Ozarks
Posts: 8
Unhappy power steering problem part 2

well, my problems continue with the power steering pump on my 2000 Z-28.
we replaced the pump in Florida and drove home. about 200 miles into the trip the steering started to get hard to turn. got home and parked the car. too many other projects. finally pulled the pump and it seems to have a stiff spot in it. going to return it (under warranty still).
My question, what is needed to remove the pulley? when the wife got the pump, she had to install the pulley with a supplied bolt. I'm guessing I need some kind of puller. any suggestions?
thank you in advance, Alex
doctor al is offline   Reply With Quote Quick reply to this message
Old Aug 6th, 10, 06:44 PM   #2 (permalink)
Senior Tech
 
Join Date: Feb 2005
Location: GULFPORT,MISSISSIPPI
Posts: 1,484
Re: power steering problem part 2

Yes you need a puller a ps pully puller rent it at autozone
__________________
"Well, the trouble with our liberal friends is not that they are ignorant, but that they know so much that isn't so." -- Ronald Reagan

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
67CAMAROSS is offline   Reply With Quote Quick reply to this message
Old Aug 6th, 10, 08:44 PM   #3 (permalink)
Senior Tech
 
Join Date: Dec 2005
Location: New Zealand
Posts: 13,316
Send a message via ICQ to Steptoe
Re: power steering problem part 2

Stiff spot..that could be the steering box adjusted down a smiggen, thu the rest of your descprition does tend to the pump.
__________________
My Spelling is not incorrect...it is creative

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Steptoe is offline   Reply With Quote Quick reply to this message
Reply
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:
Location
Location
First Name
Rather than just Hot69, gotta real name?

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Recent Discussions
Paint first or Motor...
Yesterday 04:43 PM
by AZ_Bill
Last post by Vega$69
Today 02:17 PM
11 Replies, 189 Views
Narrowing a Impala 12...
Aug 2nd, 19 01:00 PM
by X1169B
Last post by X1169B
Today 02:14 PM
19 Replies, 979 Views
electrical, radio etc...
Today 12:07 PM
Last post by SOA-Nova
Today 01:38 PM
1 Replies, 33 Views
What suspension kit for...
Yesterday 07:46 AM
by majj35
Last post by ilikeike
Today 01:36 PM
17 Replies, 274 Views
Canadian 1969 Camaro...
Jan 13th, 09 07:18 AM
Last post by RadicalRed69Camaro
Today 12:55 PM
7 Replies, 1,279 Views
Baffling suspension issue
Oct 7th, 19 04:39 PM
by Joe G
Last post by Joe G
Today 11:38 AM
39 Replies, 1,279 Views
Distributor rebuild and...
Yesterday 11:45 AM
by CDB
Last post by CDB
Today 10:45 AM
12 Replies, 238 Views
alum cylinder heads
Yesterday 01:24 PM
by ken5537
Last post by dave ray
Today 09:36 AM
3 Replies, 143 Views
Finally finishing the...
Yesterday 07:34 AM
Last post by Larry Madsen
Today 09:20 AM
1 Replies, 177 Views
Original Spark Plugs for...
Today 07:29 AM
by Niblet
Last post by Niblet
Today 09:17 AM
3 Replies, 74 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 02:23 PM.



Camaros.net - © 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.