coolant issues 00 v6 - Team Camaro Tech
Team Camaro Tech join team camaro
  



Registered users (free) do not see these large ads

Fourth Generation 1993-2002


Reply
 
LinkBack Thread Tools
Display Modes
Old Jun 29th, 13, 08:40 PM   #1 (permalink)
 
Join Date: Feb 2012
Location: Amarillo, Tx
Posts: 23
coolant issues 00 v6

Ok having issues with my coolant system. This has been happening for a while now. Ill take my rad cap off and look down in my radiator and its only about half full, so ill fill it up to the top and let it run to burp out any air in the system. The next time i drive my car the antifreeze will spew out of the top of the recovery tank. The cap on the recovery tank is vented, im assuming thats how its supposed to be. Im never able to keep my system full of antifreeze, every single time i fill it completely up, it spews out the recovery cap and it sits about half way full in the radiator. Anyone have any issues like this before? I filled it up again yesterday or so...and today when i got home from work i heard hissing and found that my radiator had blown a crack down the side of it. I figure theyre related, but whats the deal here. Any input would be appreciated, maybe i have some stoppage and need to flush it. I plan on flushing it when i put a new radiator in soon though. Thanks in advance guys.
DavidGT650R is offline   Reply With Quote Quick reply to this message
Old Jun 29th, 13, 08:48 PM   #2 (permalink)
Banned
 
Join Date: May 2006
Location: Detroit
Posts: 749
Re: coolant issues 00 v6

On modern cars, you fill the radiator once and that is it. After that, you add coolant to the recovery tank. Once the system is "settled", you read the coolant level on the recovery tank, it is marked with a line that says "full cold and full hot." Don't add water to the radiator, you are no doubt overfilling your coolant system and this is why it pukes on you.
154567 is offline   Reply With Quote Quick reply to this message
Old Jun 29th, 13, 08:58 PM   #3 (permalink)
 
Join Date: Feb 2012
Location: Amarillo, Tx
Posts: 23
Re: coolant issues 00 v6

I figuered the radiator would be full though, but yeah that makes sence. Thanks man
DavidGT650R is offline   Reply With Quote Quick reply to this message
Old Jun 30th, 13, 03:44 PM   #4 (permalink)
Gold Lifetime Member
 
Join Date: Dec 2008
Location: Louisville, Ky.
Posts: 3,403
Re: coolant issues 00 v6

Could be as simple as a bad rad cap, not pulling coolant back from the tank??
john68 is offline   Reply With Quote Quick reply to this message
Old Jun 30th, 13, 05:16 PM   #5 (permalink)
Banned
 
Join Date: May 2006
Location: Detroit
Posts: 749
Re: coolant issues 00 v6

Quote:
Originally Posted by DavidGT650R View Post
I figuered the radiator would be full though, but yeah that makes sence. Thanks man
Let us know if that was it.
154567 is offline   Reply With Quote Quick reply to this message
Old Jul 1st, 13, 05:09 PM   #6 (permalink)
 
Join Date: Feb 2012
Location: Amarillo, Tx
Posts: 23
Re: coolant issues 00 v6

Well i have no idea at the moment. My radiator blew out the night i posted this. It has a brand new rad cap, and a thermostat that i replaced literally like 3 days ago
DavidGT650R is offline   Reply With Quote Quick reply to this message
Old Jul 1st, 13, 05:10 PM   #7 (permalink)
 
Join Date: Feb 2012
Location: Amarillo, Tx
Posts: 23
Re: coolant issues 00 v6

Ill buy a new radiator after i get back from vacation, for now ill be taking my crotch rocket to work....even though i just caught a nasty cold...ugh
DavidGT650R is offline   Reply With Quote Quick reply to this message
Reply
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:
Location
Location
First Name
Rather than just Hot69, gotta real name?

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Recent Discussions
Sniper in a 69
Jul 14th, 19 07:58 PM
by LeeC
Last post by jcihos
Today 08:20 AM
10 Replies, 410 Views
1969 Camaro RS Z/28 -...
Apr 28th, 15 07:29 AM
Last post by billohio
Today 07:38 AM
355 Replies, 54,002 Views
Chevrolet Certified...
Aug 16th, 19 07:24 PM
by ChuckD
Last post by ChuckD
Today 07:02 AM
6 Replies, 180 Views
Need some advice please.
Aug 16th, 19 10:18 AM
Last post by Brettallen59
Today 06:56 AM
15 Replies, 267 Views
Original factory engine...
Today 06:32 AM
Last post by Sbarboza
Today 06:32 AM
0 Replies, 27 Views
X11 Project
Dec 1st, 16 05:45 PM
Last post by Brettallen59
Today 06:27 AM
191 Replies, 18,004 Views
Install the Rear Side...
Yesterday 12:41 PM
Last post by BRICO69
Today 06:17 AM
3 Replies, 100 Views
Impressive 67 RS @ Mecum...
Aug 10th, 19 01:10 AM
Last post by The Camaro Guy
Today 06:08 AM
12 Replies, 542 Views
What dash speakers to...
Feb 25th, 19 05:33 AM
Last post by The Camaro Guy
Today 05:52 AM
21 Replies, 1,100 Views
Phased and confused
Aug 7th, 19 08:54 AM
by BOOGIES
Last post by Bry68
Today 01:15 AM
16 Replies, 402 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 08:21 AM.



Camaros.net - 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.