95 camaro idle overheating - Team Camaro Tech
Team Camaro Tech join team camaro
  



Registered users (free) do not see these large ads

Fourth Generation 1993-2002


Reply
 
LinkBack Thread Tools
Display Modes
Old Aug 17th, 13, 07:45 PM   #1 (permalink)
Tech Team
 
Join Date: Apr 2013
Location: United States
Posts: 35
95 camaro idle overheating

camaro overheating when idling ... idk if any of the square black fuses are bad . i dont have any way of testing them ... when i unplug the mass airflow sensor 2 seconds later the fans kick on ... but when i let it run normal it doesnt turn on and overheats ... anyone know what the problem could be ? i was thinking about taking it to the mechanic. usually when i start to overheat i turn on my heater and the temp goes back down.
dodgeboy121 is offline   Reply With Quote Quick reply to this message
Old Aug 17th, 13, 08:46 PM   #2 (permalink)
Tech Team
 
Join Date: May 2013
Location: decatur IN
Posts: 44
Re: 95 camaro idle overheating

Do the fans ever kick on at idle? Sounds like a bad fan switch.

Sent from AutoGuide.com App
94z28toofast is offline   Reply With Quote Quick reply to this message
Old Aug 24th, 13, 06:38 PM   #3 (permalink)
Tech Team
 
Join Date: Apr 2013
Location: United States
Posts: 35
Re: 95 camaro idle overheating

i dont believe so
dodgeboy121 is offline   Reply With Quote Quick reply to this message
Old Aug 25th, 13, 06:42 PM   #4 (permalink)
Tech Team
 
Join Date: May 2013
Location: decatur IN
Posts: 44
Re: 95 camaro idle overheating

Yep. Bad fan switch.

Sent from AutoGuide.com App
94z28toofast is offline   Reply With Quote Quick reply to this message
Old Aug 26th, 13, 07:09 PM   #5 (permalink)
Senior Tech
 
Lonnie P's Avatar
 
Join Date: Sep 2008
Location: Pittsburgh, pa
Posts: 556
Re: 95 camaro idle overheating

Those cars do not have a fan switch, the ECM controls the fans off the temp sensor located in the water pump.

These cars have 2 speed fans. When you pull the MAF, verify both fans are running.
If 1 fails there will be no low speed operation. High comes on, but at very high temps. I forget the setting, but somewhere around 230+

I fan will probably not keep it cool.
Lonnie P is offline   Reply With Quote Quick reply to this message
Reply
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:
Location
Location
First Name
Rather than just Hot69, gotta real name?

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Recent Discussions
Sniper in a 69
Jul 14th, 19 07:58 PM
by LeeC
Last post by jcihos
Today 08:20 AM
10 Replies, 411 Views
1969 Camaro RS Z/28 -...
Apr 28th, 15 07:29 AM
Last post by billohio
Today 07:38 AM
355 Replies, 54,002 Views
Chevrolet Certified...
Aug 16th, 19 07:24 PM
by ChuckD
Last post by ChuckD
Today 07:02 AM
6 Replies, 180 Views
Need some advice please.
Aug 16th, 19 10:18 AM
Last post by Brettallen59
Today 06:56 AM
15 Replies, 267 Views
Original factory engine...
Today 06:32 AM
Last post by Sbarboza
Today 06:32 AM
0 Replies, 27 Views
X11 Project
Dec 1st, 16 05:45 PM
Last post by Brettallen59
Today 06:27 AM
191 Replies, 18,004 Views
Install the Rear Side...
Yesterday 12:41 PM
Last post by BRICO69
Today 06:17 AM
3 Replies, 100 Views
Impressive 67 RS @ Mecum...
Aug 10th, 19 01:10 AM
Last post by The Camaro Guy
Today 06:08 AM
12 Replies, 542 Views
What dash speakers to...
Feb 25th, 19 05:33 AM
Last post by The Camaro Guy
Today 05:52 AM
21 Replies, 1,100 Views
Phased and confused
Aug 7th, 19 08:54 AM
by BOOGIES
Last post by Bry68
Today 01:15 AM
16 Replies, 402 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 08:22 AM.



Camaros.net - 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.