Camaro isnt running right - Team Camaro Tech
Team Camaro Tech join team camaro
  



Registered users (free) do not see these large ads

Fourth Generation 1993-2002


Reply
 
LinkBack Thread Tools
Display Modes
Old Dec 28th, 13, 12:32 AM   #1 (permalink)
 
Join Date: Sep 2013
Location: south carolina
Posts: 9
Camaro isnt running right

my 1996 Camaro hasn't been running right for the past few weeks. I've been trying to figure out the solution but have had no luck. When you go to turn her on you have to at least turn the ignition switch over three times for her to get a good start. when running if you push the gas pedal down a little too much she starts to putter bad almost like shes misfiring. She also does this when going up hills. When on the highway if I try to accelerate to keep my speed when going up a hill she starts this so I cant accelerate and I start to lose speed. I changed to spark plugs recently and she ran a little better but she still putters. The battery, alternator, fuel pump, fuel filter, and air filter are fairly new also. The BCM is old though,there seems to be an electrical problem with the car, and there was a problem with the security system when I first got the car and it wouldn't let the car start at all.. The security system has been bypassed but it still gives me problems every now and then. Any help would be great. Thanks
LoneWolf420 is offline   Reply With Quote Quick reply to this message
Old Jan 4th, 14, 05:44 AM   #2 (permalink)
 
Join Date: Jul 2010
Location: Georgia
Posts: 11
Re: Camaro isnt running right

I had a similar problem. it was the fuel pressure regulator.
davisrus is offline   Reply With Quote Quick reply to this message
Old Jan 6th, 14, 07:46 AM   #3 (permalink)
Tech Team
 
Join Date: Aug 2008
Location: PGH. PA
Posts: 76
Re: Camaro isnt running right

Is the cadillac converter plugged? Maybe a camaro catalytic converter will work.
stellar is offline   Reply With Quote Quick reply to this message
Old Jan 6th, 14, 08:00 AM   #4 (permalink)
Gold Lifetime Member
 
wiskeesour's Avatar
 
Join Date: Nov 2006
Location: A van. Down by the river.
Posts: 6,359
Send a message via Yahoo to wiskeesour
Re: Camaro isnt running right

Quote:
Originally Posted by stellar View Post
Is the cadillac converter plugged? Maybe a camaro catalytic converter will work.

Cut this out and replace with a Magnaflow unit. Your problem is a plugged cat. Basically youve replaced everything else. Cutting out a cat that old just to see if it fixes the prob wont hurt nothing. If it doesnt fix it you havent lost anything.
__________________
AE2(AW) Harley Moody, USNavy
"Master-at-Arms" for the CDWJB!!
November 26th, 2008 was my last day to serve my country as a member of the World's Greatest Navy.
Thanks Chief.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wiskeesour is offline   Reply With Quote Quick reply to this message
Reply
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:
Location
Location
First Name
Rather than just Hot69, gotta real name?

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Recent Discussions
Vinyl top trim
Aug 10th, 08 08:19 PM
by rogerh
Last post by Sabinoerc
Today 08:15 AM
29 Replies, 2,762 Views
How much will swapping...
Yesterday 09:23 PM
Last post by Farm Boy
Today 07:55 AM
4 Replies, 95 Views
The Hugger69 goes ZL-1!
Apr 15th, 16 07:00 AM
by Hgger69
Last post by Hgger69
Today 07:47 AM
220 Replies, 24,695 Views
Kind of cool day for me
Aug 19th, 19 07:50 AM
Last post by Just 1 More
Today 07:43 AM
20 Replies, 776 Views
Tail light lense...
Yesterday 06:16 PM
Last post by daven1256
Today 07:13 AM
5 Replies, 99 Views
And another question
Yesterday 04:10 AM
by ktrim
Last post by Triman8654
Today 06:20 AM
1 Replies, 100 Views
69 rustbucket rebirth
Jul 22nd, 13 11:38 AM
Last post by 350sshugger
Today 06:18 AM
1 Replies, 182,372 Views
Earl's Vapor Guard Hose...
Today 05:52 AM
Last post by dhutton
Today 06:15 AM
1 Replies, 37 Views
Shock from horn
Aug 22nd, 19 06:59 AM
Last post by boyd66k20
Today 05:28 AM
10 Replies, 222 Views
Looking for suitable...
Aug 21st, 19 08:05 PM
Last post by Brettallen59
Today 04:55 AM
5 Replies, 159 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 08:51 AM.



Camaros.net - 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.