Need help with emissions! - Team Camaro Tech
Team Camaro Tech join team camaro
  



Registered users (free) do not see these large ads

Fourth Generation 1993-2002


Reply
 
LinkBack Thread Tools
Display Modes
Old Aug 11th, 14, 02:18 PM   #1 (permalink)
 
Join Date: Aug 2014
Location: Phoenix, AZ
Posts: 6
Need help with emissions!

Hey i'm a new user to this website. Although I've read many posts, this is my first.

I have a 1994 v6 3.4L Camaro with 143k Miles and when ever the car is running or was recently running there is an exhaust smell that almost smells a bit like raw gasoline. There are a few factors to narrow this smell down however.

My Emissions Test --- This Car/Accepted Limit
-----------------
Hydrocarbons(HC)Grams/Mile --- 2.94 --- 0.80
Carbon Monoxide(CO)Grams/Mile --- 83.97 --- 12.00
Oxides of Nitrogen(NOX)Grams/Mile --- 1.80 --- 2.00

THE VEHICLE HAS PASSED THE EQUIPMENT INSPECTION
THE VEHICLE HAS FAILED THE EMISSIONS TEST

There is a small amount of white smoke on start up that I'm pretty sure is oil leaking into the combustion chamber but I don't think this is what I'm smelling. What other reason could there be for my car to fail emissions like this and have this smell?

I've changed the air filter, fuel filter, spark plugs/wires, oil, radiator flushed and recently seafoamed the brake booster intake. I haven't taken it back through emissions testing because i am afraid the smell is the cause of my failure. I was told oil burning will not fail my car.

The previous owner put the z28 decal on but it isn't a z28


Jack Frost is offline   Reply With Quote Quick reply to this message
Old Aug 12th, 14, 09:50 AM   #2 (permalink)
 
Join Date: Aug 2014
Location: Phoenix, AZ
Posts: 6
Re: Need help with emissions!

I cant figure out how to edit this post so its going to be a reply..

UPDATE: I have located the charcoal filter and its stinky! Could this be failing my emissions test?
Jack Frost is offline   Reply With Quote Quick reply to this message
Old Aug 12th, 14, 12:07 PM   #3 (permalink)
Senior Tech
 
Join Date: Jun 2013
Location: Norman, Ok
Posts: 711
Re: Need help with emissions!

If the charcoal canister is not working properly then yes it could be causing it to fail. Also, are the factory catalytic converters still on the vehicle? If they are not there, (some people remove the cats to improve air flow) your vehicle will fail every emissions test there is. Are you sure it is white smoke? Coolant usually burns white, or if it is water should i say steams out. All of these can cause you to fail an emissions test.
__________________
1967 RS/SS Camaro 383 5 speed tremec 3.70
1967 RS/SS Camaro 383 5 speed tremec 4.10
1967 RS Camaro Convertible 327 4 speed 3.73
1969 SS Camaro 6.0 LS Twin Turbo 5 Speed 3.50
2013 ZL1 Camaro roto-fab airbox pulley swap Rest In Pieces March 27 2014
FTF Automotive is offline   Reply With Quote Quick reply to this message
Old Aug 12th, 14, 12:12 PM   #4 (permalink)
 
Join Date: Aug 2014
Location: Phoenix, AZ
Posts: 6
Re: Need help with emissions!

Quote:
Originally Posted by FTF Automotive View Post
If the charcoal canister is not working properly then yes it could be causing it to fail. Also, are the factory catalytic converters still on the vehicle? If they are not there, (some people remove the cats to improve air flow) your vehicle will fail every emissions test there is. Are you sure it is white smoke? Coolant usually burns white, or if it is water should i say steams out. All of these can cause you to fail an emissions test.

I am pretty sure the cat is still on there because I passed all the equipment inspections but i should get under there and look. As for the smoke it looks white but i guess they called it bluish white... I haven't had it back through emissions since i've done all this work so im not sure that it will pass or fail but maybe this bit of information can help you diagnose it a little more.. When i am idling at a light for about a minute my service engine light comes on but once i get moving it shuts off.
Jack Frost is offline   Reply With Quote Quick reply to this message
Old Aug 12th, 14, 12:23 PM   #5 (permalink)
 
Join Date: Aug 2014
Location: Phoenix, AZ
Posts: 6
Re: Need help with emissions!

Quote:
Originally Posted by FTF Automotive View Post
If the charcoal canister is not working properly then yes it could be causing it to fail. Also, are the factory catalytic converters still on the vehicle? If they are not there, (some people remove the cats to improve air flow) your vehicle will fail every emissions test there is. Are you sure it is white smoke? Coolant usually burns white, or if it is water should i say steams out. All of these can cause you to fail an emissions test.
I know I do have a small coolant leak, more of a build up than a drip, under the radiator.
Jack Frost is offline   Reply With Quote Quick reply to this message
Old Aug 13th, 14, 10:21 AM   #6 (permalink)
Senior Tech
 
Join Date: Jun 2013
Location: Norman, Ok
Posts: 711
Re: Need help with emissions!

ok so, you know that you have something going on, if you are kicking a check engine light. Do you have an autozone or similar auto parts store that will put a code reader on it for you? Your engine could be doing all sorts of funny things to keep it running, which could be attributing to the running rich condition, which can also cause it to fail emissions.
__________________
1967 RS/SS Camaro 383 5 speed tremec 3.70
1967 RS/SS Camaro 383 5 speed tremec 4.10
1967 RS Camaro Convertible 327 4 speed 3.73
1969 SS Camaro 6.0 LS Twin Turbo 5 Speed 3.50
2013 ZL1 Camaro roto-fab airbox pulley swap Rest In Pieces March 27 2014
FTF Automotive is offline   Reply With Quote Quick reply to this message
Old Aug 13th, 14, 11:26 AM   #7 (permalink)
 
Join Date: Aug 2014
Location: Phoenix, AZ
Posts: 6
Re: Need help with emissions!

Quote:
Originally Posted by FTF Automotive View Post
ok so, you know that you have something going on, if you are kicking a check engine light. Do you have an autozone or similar auto parts store that will put a code reader on it for you? Your engine could be doing all sorts of funny things to keep it running, which could be attributing to the running rich condition, which can also cause it to fail emissions.
Yea i would check the codes but here's the thing.. autozone doesnt do the code reader for my old car unless the check engine light stays on but as i said its on when i idle then it goes away once I either give her a couple revs or once I get moving..
Jack Frost is offline   Reply With Quote Quick reply to this message
Reply

Tags
1994
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:
Location
Location
First Name
Rather than just Hot69, gotta real name?

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Recent Discussions
VIN history & cowl tag...
Feb 2nd, 20 12:18 PM
Last post by GatorDale
Today 09:48 PM
24 Replies, 1,001 Views
1969 right hand drive...
Today 09:44 PM
Last post by Riffraff53
Today 09:44 PM
0 Replies, 2 Views
Tim's 69 Grocery Getter
Dec 11th, 18 07:23 PM
Last post by dhutton
Today 08:30 PM
218 Replies, 13,974 Views
Hi team camaro, well...
Feb 13th, 20 04:43 AM
Last post by RDW
Today 07:48 PM
4 Replies, 191 Views
Hi New member here just...
Today 06:53 AM
Last post by RDW
Today 07:46 PM
6 Replies, 101 Views
67 dash chrome bezels
Feb 14th, 20 03:54 PM
Last post by r_w
Today 07:14 PM
7 Replies, 202 Views
Ls3 camshaft
Today 07:12 PM
Last post by stamatisg1977
Today 07:12 PM
0 Replies, 22 Views
Horn Headache
Today 01:42 PM
Last post by Brettallen59
Today 06:59 PM
7 Replies, 122 Views
3D Printed Grommet
Today 05:37 AM
by r_w
Last post by r_w
Today 06:59 PM
4 Replies, 112 Views
OC MD crack down...
Today 08:28 AM
by DOUG G
Last post by X-77 keith
Today 05:55 PM
3 Replies, 108 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 10:10 PM.



Camaros.net - 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.