1995 braking issues ? - Team Camaro Tech
Team Camaro Tech join team camaro
  



Registered users (free) do not see these large ads

Fourth Generation 1993-2002


Reply
 
LinkBack Thread Tools
Display Modes
Old Sep 8th, 14, 03:04 PM   #1 (permalink)
Tech Team
 
Join Date: Apr 2013
Location: United States
Posts: 35
1995 braking issues ?

hey guys im having some issues with my camaro's brakes and its progressing.
when im driving and slow down quickly nothing happens it stops as normal.
but when i come to a gentle slow (driving as normal approaching a stop) the pedal feels like the abs is coming on. it kicks back and says low traction and the car kinda lunges forward a little.

anyway ideas of what this may be?

oh btw i was in a wreck in may and the impact was on the LR wheel,visually there isnt a whole lot of damage, mechanically seems to be working, but the car hit me going at least 15 to 20 mph faster than i was ( i was turning off the highway and he wasnt paying attention)
anyway is there any sensors in the wheel area that may have been damaged or anything..

anyway input would be very well appreciated, i want this car safe to drive on a counting i also share it with my mom, and her safety is my concern here.
thank you guys - Aaron
dodgeboy121 is offline   Reply With Quote Quick reply to this message
Old Sep 9th, 14, 12:28 PM   #2 (permalink)
Gold Lifetime Member
 
Join Date: Oct 2007
Location: San Diego, CA
Posts: 2,717
Re: 1995 braking issues ?

Might be the wheel sensor on the side you were hit on (left rear).

I had a similar thing happen on my 02 Z28 (ABS made brake pedal pulsate and feel stiff and the Low Trac light would come on). I took it to the dealer and they said it was the wheel brake sensor (right rear in my case). Seems it had gotten contaminated some how and it was malfunctioning causing the symptoms you described. They replaced the sensor and it now works fine.
__________________
67 Camaro: 454/TH400/4.10 12 bolt. Lots of options: PS/PDB/PW, tilt, tach, gauges and more. K-K + 797-Z...

"Politics is the art of looking for trouble, finding it whether it exists or not, diagnosing it incorrectly and applying the wrong remedy" - Sir Ernest Benn
PowerWindows is offline   Reply With Quote Quick reply to this message
Reply
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:
Location
Location
First Name
Rather than just Hot69, gotta real name?

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Recent Discussions
I’m baffled BBC won’t...
Today 03:56 PM
by GI69cam
Last post by TJS69
Today 11:22 PM
9 Replies, 109 Views
1969 Camaro RS Z/28 -...
Apr 28th, 15 07:29 AM
Last post by Edgemontvillage
Today 11:17 PM
358 Replies, 54,048 Views
AR105 Torqu Thrust -...
Apr 10th, 19 02:10 AM
by majj35
Last post by martin349
Today 10:45 PM
3 Replies, 356 Views
Alternator died, now no...
Jun 11th, 19 09:21 AM
Last post by robe9000
Today 09:51 PM
4 Replies, 196 Views
Original factory engine...
Today 06:32 AM
Last post by Farm Boy
Today 09:48 PM
8 Replies, 188 Views
Timing question
Today 02:59 PM
Last post by allanjs
Today 08:17 PM
5 Replies, 91 Views
Phased and confused
Aug 7th, 19 08:54 AM
by BOOGIES
Last post by BOOGIES
Today 08:07 PM
17 Replies, 437 Views
Name is Gary, hope to...
Today 04:13 PM
by GI69cam
Last post by GI69cam
Today 07:41 PM
6 Replies, 88 Views
Hagerty Pricing Guide
Today 10:54 AM
by rogerh
Last post by 69L48Z27
Today 07:07 PM
4 Replies, 131 Views
Repop bumpers?
Aug 8th, 19 05:49 PM
by 3d cad
Last post by jimnecci
Today 06:17 PM
13 Replies, 492 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 11:33 PM.



Camaros.net - 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.