Horn keeps going off and security light is on - Team Camaro Tech
Team Camaro Tech join team camaro
  



Registered users (free) do not see these large ads

Fourth Generation 1993-2002


Reply
 
LinkBack Thread Tools
Display Modes
Old Dec 11th, 14, 12:21 PM   #1 (permalink)
 
Join Date: Jan 2014
Posts: 2
Horn keeps going off and security light is on

I just bought a 1996 Chevy Camaro Z28 and the security light is on. The horn wasn't working either but I put in a fuse under the hood. Now the horn works but sometimes the horn will go off for no reason and won't turn off, sound just like someone is holding the horn down and not letting off. I'm thinking this has something to do with the security light being on because the previous owner said they had to bypass the security system in the Car. I need the horn to work normally to have the car pass inspection. Just wanting the horn to quit going off randomly, I don't care about the light. Any help is appreciated, thank you.
scottypeterson is offline   Reply With Quote Quick reply to this message
Old Dec 11th, 14, 12:32 PM   #2 (permalink)
Senior Tech
 
cv2065's Avatar
 
Join Date: Jul 2012
Location: Orlando, FL
Posts: 1,193
Re: Horn keeps going off and security light is on

Did you inspect the horn assembly in the steering column? Might want to get a diagram and check the order in which its put together. Easy to get those things confused. Also check the condition of the metal contact flat spring. Not really a spring, just a metal disc.
__________________
67 Black RS Coupe, 383, M21 & 10 Bolt Posi. Edelbrock E-Tech 170 Heads, 2204 Roller Cam, Air Gap Intake.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cv2065 is offline   Reply With Quote Quick reply to this message
Old Dec 11th, 14, 09:09 PM   #3 (permalink)
Senior Tech
 
Join Date: Nov 2010
Location: boston ma.
Posts: 841
Re: Horn keeps going off and security light is on

Is it a factory alarm system or aftermarket If it is aftermarket just get rid of it and your problem will most likely go away. Aftermarket alarms are only as good as the quality of the alarm and the man that is wiring it into your harness. there is the right way and the wrong way there are also a ton of shortcuts. it has been our experience with VATS system problems mostly occur with poorly wired and inexpensive aftermarket alarms. Alex
ss27 is offline   Reply With Quote Quick reply to this message
Reply
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:
Location
Location
First Name
Rather than just Hot69, gotta real name?

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Recent Discussions
1969 Camaro RS Z/28 -...
Apr 28th, 15 07:29 AM
Last post by billohio
Today 07:38 AM
355 Replies, 54,002 Views
Chevrolet Certified...
Aug 16th, 19 07:24 PM
by ChuckD
Last post by ChuckD
Today 07:02 AM
6 Replies, 178 Views
Need some advice please.
Aug 16th, 19 10:18 AM
Last post by Brettallen59
Today 06:56 AM
15 Replies, 266 Views
Original factory engine...
Today 06:32 AM
Last post by Sbarboza
Today 06:32 AM
0 Replies, 26 Views
X11 Project
Dec 1st, 16 05:45 PM
Last post by Brettallen59
Today 06:27 AM
191 Replies, 18,004 Views
Sniper in a 69
Jul 14th, 19 07:58 PM
by LeeC
Last post by jkuro
Today 06:19 AM
9 Replies, 406 Views
Install the Rear Side...
Yesterday 12:41 PM
Last post by BRICO69
Today 06:17 AM
3 Replies, 100 Views
Impressive 67 RS @ Mecum...
Aug 10th, 19 01:10 AM
Last post by The Camaro Guy
Today 06:08 AM
12 Replies, 542 Views
What dash speakers to...
Feb 25th, 19 05:33 AM
Last post by The Camaro Guy
Today 05:52 AM
21 Replies, 1,099 Views
Phased and confused
Aug 7th, 19 08:54 AM
by BOOGIES
Last post by Bry68
Today 01:15 AM
16 Replies, 402 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 08:13 AM.



Camaros.net - 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.