"New" 1999. Oil pressure too high - Team Camaro Tech
Team Camaro Tech join team camaro
  



Registered users (free) do not see these large ads

Fourth Generation 1993-2002


Reply
 
LinkBack Thread Tools
Display Modes
Old Mar 5th, 16, 01:55 PM   #1 (permalink)
 
Join Date: Sep 2006
Location: Stillwater, OK
Posts: 26
"New" 1999. Oil pressure too high

Hi everyone,
My last post was obviously too long. My 1999 base Camaro with 3.8L seems to run well, no smoke, but the oil pressure reads ~100 most of the time. Maybe 100+. The car doesn't leak oil (much), but I know nothing about this car's history.

After searching and researching this sounds like a bad sending unit probably... correct?

Other facts: Sometimes the gauge reads about 60 at idle, sometimes it stays high. The gauge responds to engine speed (goes up with increasing RPMs). Finally, the gauge will twitch or flicker slightly at idle which makes it look like it has an electrical problem. I don't have a manual gauge to stick on and check oil pressure, so can you experts reassure me that buying a new sender is a reasonable course of action?

Thanks,
Peter
PeteHoyt is offline   Reply With Quote Quick reply to this message
Old Mar 5th, 16, 04:22 PM   #2 (permalink)
Senior Tech
 
ZZ_430's Avatar
 
Join Date: May 2001
Location: Houston, Texas
Posts: 4,491
Re: "New" 1999. Oil pressure too high

I'd say there is a 99% chance the sender is out of spec.

For what it costs and ease of changing it, I'd do it.
__________________
Don ~ TC Member #15 ~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Don't mess with Texas!
ZZ_430 is offline   Reply With Quote Quick reply to this message
Old Mar 5th, 16, 07:16 PM   #3 (permalink)
 
Join Date: Sep 2006
Location: Stillwater, OK
Posts: 26
Re: "New" 1999. Oil pressure too high

Yeah, thanks. I just want to make sure I hadn't missed something.
PeteHoyt is offline   Reply With Quote Quick reply to this message
Old Apr 9th, 16, 11:11 AM   #4 (permalink)
 
Join Date: Sep 2006
Location: Stillwater, OK
Posts: 26
Re: "New" 1999. Oil pressure too high

Just to follow up on this. The new pressure sender worked mostly. Now my pressure readings are between 50 and 90. Still seems high, but I'm more comfortable with them. Plan to get a mechanical gauge soon to check.
Thanks.
Pete
PeteHoyt is offline   Reply With Quote Quick reply to this message
Old Apr 9th, 16, 04:06 PM   #5 (permalink)
Moderator
 
DOUG G's Avatar
 
Join Date: Mar 1999
Location: Maryland, USA
Posts: 19,293
Garage
Send a message via MSN to DOUG G
Re: "New" 1999. Oil pressure too high

What weight oil and what filter ?
__________________
68 Camaro~LSx ~all motor
1.54 60'--6.95 @ 98.45 660'--10.96 @ 121.53
DOUG G is offline   Reply With Quote Quick reply to this message
Old Apr 23rd, 16, 02:42 PM   #6 (permalink)
 
Join Date: Sep 2006
Location: Stillwater, OK
Posts: 26
Re: "New" 1999. Oil pressure too high

I really don't know. but plan to have 5W-40 in by the end of the weekend.

Is there a better filter I should know about? Please share.

Peter
PeteHoyt is offline   Reply With Quote Quick reply to this message
Reply
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:
Location
Location
First Name
Rather than just Hot69, gotta real name?

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


» Recent Discussions
Vinyl top trim
Aug 10th, 08 08:19 PM
by rogerh
Last post by Sabinoerc
Today 08:15 AM
29 Replies, 2,762 Views
How much will swapping...
Yesterday 09:23 PM
Last post by Farm Boy
Today 07:55 AM
4 Replies, 95 Views
The Hugger69 goes ZL-1!
Apr 15th, 16 07:00 AM
by Hgger69
Last post by Hgger69
Today 07:47 AM
220 Replies, 24,695 Views
Kind of cool day for me
Aug 19th, 19 07:50 AM
Last post by Just 1 More
Today 07:43 AM
20 Replies, 776 Views
Tail light lense...
Yesterday 06:16 PM
Last post by daven1256
Today 07:13 AM
5 Replies, 99 Views
And another question
Yesterday 04:10 AM
by ktrim
Last post by Triman8654
Today 06:20 AM
1 Replies, 100 Views
69 rustbucket rebirth
Jul 22nd, 13 11:38 AM
Last post by 350sshugger
Today 06:18 AM
1 Replies, 182,372 Views
Earl's Vapor Guard Hose...
Today 05:52 AM
Last post by dhutton
Today 06:15 AM
1 Replies, 37 Views
Shock from horn
Aug 22nd, 19 06:59 AM
Last post by boyd66k20
Today 05:28 AM
10 Replies, 222 Views
Looking for suitable...
Aug 21st, 19 08:05 PM
Last post by Brettallen59
Today 04:55 AM
5 Replies, 159 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 08:51 AM.



Camaros.net - 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.