My '95 Camaro Z-28 just stopped running. - Team Camaro Tech
Team Camaro Tech join team camaro
  



Registered users (free) do not see these large ads

Fourth Generation 1993-2002


Reply
 
LinkBack Thread Tools
Display Modes
Old May 9th, 06, 09:36 PM   #1 (permalink)
 
Join Date: Oct 2005
Posts: 32
Unhappy My '95 Camaro Z-28 just stopped running.

I was at a stop light. When the light turned green I went and about a minute later, my car just dies and I coasted to a stop. After about 15 minutes, I tried to start it again. It cranked over but it took awhile for the engine finally turn over and then I drove it until it died again just down the street from my house. When I cranked it over again it started to cough but then it finally turned over again in which I made it home. I know it sounds like a fuel pump but, I had a new one installed about 3 months ago and I am getting fuel. My guess is that my distributor is bad because I noticed that it was leaking some coolant at the water pump just above the distributor connection and that there was some moisture present. What do you guys think? Could something else be wrong as well?
Rokbrigade is offline   Reply With Quote Quick reply to this message
Old May 9th, 06, 10:36 PM   #2 (permalink)
Tech Team
 
Join Date: Jan 2004
Posts: 59
Re: My '95 Camaro Z-28 just stopped running.

Id check all of your electrical connections also, I had a ground come loose near my main power block (the red one near the battery) come loose from a broken bolt that caused the car to act funny, didn't die on me but tried to.
Other than that it maybe the optical part of the distributor going bad. Its a common thing to go bad on the Lt-1's so it would be the obvious place to look.

I noticed a lot of people post on here about 4th gens and don't really get any answers considering this is mostly a 1st gen site. If you want a lot more info check out www.camaroz28.com for 4th gen stuff. You'll probably get a lot more answers.
RicocheT25 is offline   Reply With Quote Quick reply to this message
Reply
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:
Location
Location
First Name
Rather than just Hot69, gotta real name?

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
69 Camaros on television and movies jsg1010z Bench Racing 35 Aug 15th, 10 05:28 PM
New 69 CAMARO bodies coporic Bench Racing 16 Feb 25th, 07 08:08 AM
95 Camaro 3.4L V6 Running Rough Camaro Rookie Troubleshooting 3 May 2nd, 06 07:39 PM
A big thanks to team camaro!!! 68 VT Bench Racing 13 Feb 28th, 06 04:41 AM
2004 SuperCar Reunion Labor Day weekend HawaiianCamaro Team Camaro Cruiz-Ins 1 Aug 25th, 04 08:51 PM

» Recent Discussions
awaiting spring
Today 04:00 AM
Last post by 3d cad
Today 06:04 PM
11 Replies, 127 Views
BBC water bypass line
Yesterday 07:12 PM
by Foss396
Last post by Lonnie P
Today 06:03 PM
10 Replies, 157 Views
The Hugger69 goes ZL-1!
Apr 15th, 16 07:00 AM
by Hgger69
Last post by bradss396
Today 05:58 PM
237 Replies, 26,736 Views
Need the carb guy's
Today 05:55 PM
Last post by stevo camaro
Today 05:55 PM
0 Replies, 9 Views
Mirrors, Screws, D & R...
Oct 12th, 19 05:00 PM
by blm
Last post by blm
Today 04:38 PM
23 Replies, 810 Views
Issue With Front...
Today 04:18 AM
Last post by Brettallen59
Today 04:28 PM
23 Replies, 251 Views
Quiet High Performance...
Oct 18th, 19 07:18 PM
Last post by ss27
Today 04:16 PM
5 Replies, 175 Views
Adapter part # ?
Yesterday 02:33 PM
by 3d cad
Last post by dhutton
Today 04:12 PM
5 Replies, 138 Views
1 owner 67 rs 4 spd So...
Yesterday 04:57 PM
by cv67
Last post by Garfields Maro
Today 03:31 PM
7 Replies, 166 Views
Baffling suspension issue
Oct 7th, 19 04:39 PM
by Joe G
Last post by Joe G
Today 03:26 PM
32 Replies, 1,065 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 06:05 PM.



Camaros.net - 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.