Oil Pressure question - Team Camaro Tech
Team Camaro Tech join team camaro
  



Registered users (free) do not see these large ads

Fourth Generation 1993-2002


Reply
 
LinkBack Thread Tools
Display Modes
Old Jan 30th, 07, 01:21 PM   #1 (permalink)
 
Join Date: Mar 2006
Posts: 22
Oil Pressure question

I am looking at a 1995 Camaro with the 3.4L V6 for a daily driver. Drove it today and noticed the low oil light was on at start up. Turned it off and checked the oil level- plenty of oil. Started it up again, low oil light on for a minute, then goes off. Faulty oil pressure sensor? The oil pressure guage also seemed to read low at idle after the car was warm. What is the typical oil pressure for a warm 3.4 V6? This car has 123000 miles. Any help would be appreciated.
crucescamaro is offline   Reply With Quote Quick reply to this message
Old Jan 31st, 07, 04:24 AM   #2 (permalink)
Super Moderator
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,622
Garage
Re: Oil Pressure question

I would probably say pressure sensor needing replacement first.

Normnal oil pressure is the same as a SBC, 40-50 hot @ 2000-2500 rpm, 15-25 @ hot idle.

However, oil filter points down or sideways, oil drains out over night, start-up cold or after sitting for a long time, pump has to fill up the filter first.
__________________
Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - maybe this year, 2019 ...
Everett#2390 is offline   Reply With Quote Quick reply to this message
Old Feb 1st, 07, 03:02 PM   #3 (permalink)
 
Join Date: Jan 2007
Posts: 19
Re: Oil Pressure question

Oil pressure sending unit possible.
Badmeds is offline   Reply With Quote Quick reply to this message
Old Mar 20th, 07, 04:05 PM   #4 (permalink)
 
Join Date: Mar 2007
Posts: 21
Re: Oil Pressure question

I've got a '94 3.4L and I've had to change the oil pressure sending unit at least 5 times (maybe 8, can't remember) since 1994. This also happened on an '84 Firebird many years ago. In all cases the gauge started jumping all over the place (from 0 to 80 psi, and any place in between, for no apparent reason). It's fairly easy to change when replacing the filter.

hope this helps
Brad
justbrad is offline   Reply With Quote Quick reply to this message
Old Jun 28th, 07, 03:12 PM   #5 (permalink)
 
Join Date: Mar 2006
Posts: 22
Re: Oil Pressure question

Thanks for the input guys. I ended up buying another Camaro instead of this one. See my latest post for this cars woes...
crucescamaro is offline   Reply With Quote Quick reply to this message
Reply
Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.

Email Address:
Location
Location
First Name
Rather than just Hot69, gotta real name?

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil pressure issue DirtyScotty Engine 14 Aug 21st, 06 06:43 PM
leaking oil...is my pressure to high? Eighttrakz Engine 14 May 11th, 06 10:39 AM
oil pressure question/problem. iroc5570 Engine 6 Aug 27th, 05 11:08 AM
Oil Pressure Drop BBC 68camtruck Engine 3 May 5th, 05 04:16 AM

» Recent Discussions
Shock from horn
Aug 22nd, 19 06:59 AM
Last post by The Camaro Guy
Today 05:32 AM
15 Replies, 464 Views
Muncie shifting trouble
Yesterday 06:59 AM
Last post by R66
Today 05:31 AM
8 Replies, 168 Views
Adding...
Sep 15th, 19 05:57 AM
Last post by 350sshugger
Today 05:28 AM
9 Replies, 228 Views
Steering Arm Problem 68...
Sep 15th, 19 02:18 PM
Last post by R66
Today 05:18 AM
3 Replies, 160 Views
Kind of cool day for me
Aug 19th, 19 07:50 AM
Last post by rgwiz
Today 04:59 AM
24 Replies, 1,092 Views
Took home my 2nd Best in...
Yesterday 06:37 AM
Last post by rgwiz
Today 04:56 AM
8 Replies, 167 Views
carb tuning with...
Yesterday 08:47 AM
Last post by HawkX66
Today 04:49 AM
12 Replies, 157 Views
Coil Bracket
Today 03:34 AM
Last post by KevinW
Today 04:31 AM
2 Replies, 42 Views
Mid-pipes
Today 04:26 AM
Last post by bruce69camaro
Today 04:26 AM
0 Replies, 14 Views
Door glass won't adjust...
Sep 14th, 19 01:02 PM
by ssanto
Last post by johnpetty112
Today 12:17 AM
3 Replies, 159 Views
Powered by vBadvanced CMPS v3.2.3

All times are GMT -7. The time now is 05:40 AM.



Camaros.net - © 2009 AutoForums.com
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.