67 camaro headlight motors keep running - Team Camaro Tech
New Member Introductions New here? Please introduce yourself.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Feb 20th, 08, 12:12 PM Thread Starter
 
Join Date: Feb 2008
Posts: 2
Question 67 camaro headlight motors keep running

New member here, this is a great forum.
My 67 camaro door motor on one side continues to run after it closes. Can someone please give me an idea of the cause. Is it a limit switch, relay etc? Also maybe tell me how to check it out. The motors are less than a year. I ordered them from Rick's Camaro. Thanks for any help.
redragtop68 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Feb 20th, 08, 12:22 PM
Senior Tech
James
 
Join Date: Sep 2004
Location: Fairview Heights, IL
Posts: 336
Send a message via Yahoo to james7773
Re: 67 camaro headlight motors keep running

It sounds like its a stop limit switch. You can test this by pressing the limit switch shut. Check to be sure the headlight cover is making good contact with the switch. If you think it might be a faulty switch, try swapping the one on the side that is working with the one that isnt. (Ive been through the same nightmares with mine)
Good luck.

My 67 RS 327...its a work in progress.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
james7773 is offline  
post #3 of 4 (permalink) Old Feb 21st, 08, 07:37 AM Thread Starter
 
Join Date: Feb 2008
Posts: 2
Re: 67 camaro headlight motors keep running

Thanks James, will give it a shot.
redragtop68 is offline  
 
post #4 of 4 (permalink) Old Feb 21st, 08, 10:08 AM
Team Member
Jerry R.
 
jr68's Avatar
 
Join Date: Aug 2000
Location: The Great Lakes
Posts: 6,106
Re: 67 camaro headlight motors keep running

welcome

my Magnaflow X-pipe system sound clip, click the link


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jr68 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome