'68 Camaro Research - Team Camaro Tech
New Member Introductions New here? Please introduce yourself.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Jul 28th, 10, 06:49 PM Thread Starter
JHN
Tech Team
John
 
Join Date: Jul 2010
Location: PA
Posts: 38
'68 Camaro Research

Just purchased a '68 Camaro and wondering how to research the original details about how the car came off the line - engine, RS or SS, interior, etc. I found out how to decode the VIN and found out it was originally an 8cyl, std interior, built in CA. Are there other numbers somewhere else on the car that would tell me all the other detail? Anyone know where I should look? Once I find the detail from the car, where can I go to research? thx. JHN
JHN is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Jul 28th, 10, 09:10 PM
Gold Lifetime Member
Bryon
 
bcm66's Avatar
 
Join Date: Apr 2006
Location: Nebraska
Posts: 4,661
Re: '68 Camaro Research

Lots of information at this link if you search around.
http://www.camaros.org/index.shtml

68 Camaros are tough to figure out other than what you have found out from the VIN. Exterior color and interior codes are on the cowl tag/Fisher body tag. Go here to decode those or post the information and I can help.
http://www.camaros.org/numbers.shtml#CowlTag

Check here for some information on 68s specifically.
http://www.camaros.org/diffs68.shtml

Engine codes are at this link.
http://www.camaros.org/drivetrain.shtml#PadStamps

I just had to do the same thing with my car in the past few years so I will be able to answer some of your questions. It will be harder to figure out if the original engine, transmission and rear end are gone.

68 Camaro SS 396 - 468 BBC now, M21, 12 bolt 3.73 coded housing but w/ 3.31 gears.
Looking for 68 Camaro with body number NOR 181016
CRG -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bcm66 is offline  
post #3 of 3 (permalink) Old Sep 29th, 10, 07:59 PM Thread Starter
JHN
Tech Team
John
 
Join Date: Jul 2010
Location: PA
Posts: 38
Re: '68 Camaro Research

Thanks for the reply - very helpful
I recently pinched the smaller wire attached to the positive battery cable between the battery and the inside of the fender. It melted in half. The car would not start. I repaired with a splice and the car started - but when I turn the ignition off, the car still runs. Any idea why? Did I burn something else out? Anyone have any ideas? thx
JHN is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome