blown fuse - Team Camaro Tech
New Member Introductions New here? Please introduce yourself.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Apr 23rd, 11, 10:31 PM Thread Starter
TomC
 
Join Date: Apr 2011
Location: missouri
Posts: 1
blown fuse

my 68 blows the wiper fuse when you first turn the ign. key on even with the wiper switch in the off position. will even do it with motor unplugged
Tommytucker is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Apr 24th, 11, 05:52 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 32,180
Garage
Re: blown fuse

Unplug the switch as ignition voltage comes to the sw and sw applies a dash ground when wipers are turned on. If fuse stays, then bad switch or pinched wire.
Measure short to ground with ohmmeter.
Also, if electric choke is added and power is from the same source, or another electrical device is added to same circuit, fuse would need to be bigger as by design, fuse only handles wiper motor and washer pump.

Welcome to the Club, Tom. You'll be flogged for pictures, just an early warning. Correct year by the way.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden Ö enjoy your next chapter.
Everett#2390 is offline  
post #3 of 4 (permalink) Old Apr 24th, 11, 08:49 AM
Gold Lifetime Member
Jeff
 
yellow69RS's Avatar
 
Join Date: Jul 2007
Location: Aurora, IL
Posts: 5,270
Send a message via Yahoo to yellow69RS
Re: blown fuse

Don't know if 68 different from 69 but no power to 69 wiper switch. Sounds like a short in the wire to the wiper motor or additional accesorries added to the wiper circuit.

Jeff
yellow69RS is offline  
 
post #4 of 4 (permalink) Old Apr 24th, 11, 09:15 AM
Team Member
Jerry R.
 
jr68's Avatar
 
Join Date: Aug 2000
Location: The Great Lakes
Posts: 6,106
Re: blown fuse

welcome to welcome wagon

my Magnaflow X-pipe system sound clip, click the link


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jr68 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome