Need sending unit for GM32AFI tank - Team Camaro Tech
EFI in your modern Classic EFI conversions in early Camaros

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Feb 28th, 11, 09:08 AM Thread Starter
Tech Team
john
 
Join Date: Jan 2009
Location: kentucky
Posts: 74
Need sending unit for GM32AFI tank

I have a 69 that i installed a LT1 in a while back, Been running ok with full tank but when gets below 1/2 tank cuts out, so i pulled the pump sending unit assembly to see what may be the problem. Found that the bowl in the tank had no holes for the fuel to get into other than 1 in the bottom where the bowl meets the tank. so i but some extra holes in the bowl for gas to get in and seems to help. But when doing so i must have damaged my sending unit because now my gas gage don't work. Th e tank is a GM32AFI tank, so i called rock auto and they told me i had to buy the whole tank with assembly. Does any one know where i can get a sending unit for this tank? or another allternative to my problem.
69camconv is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Mar 18th, 11, 01:15 PM
 
Join Date: Mar 2011
Location: SoCal
Posts: 2
Re: Need sending unit for GM32AFI tank

From the part number, it seems the tank is made by Spectra Premium? I had a problem with my tank's sending unit too and emailed them. They sent me a new sending unit at no charge. You can find their contact info on their website.
7T3LS1 is offline  
post #3 of 3 (permalink) Old Mar 18th, 11, 02:08 PM
Gold Lifetime Member
John
 
Vintage 68's Avatar
 
Join Date: Mar 2002
Location: Moraga,Ca.,USA
Posts: 13,705
Wink Re: Need sending unit for GM32AFI tank

Old duplicate thread
See - https://www.camaros.net/forums/showthread.php?t=192266

ps: this is why we duplicate threads

1968 Convertible
Some trucks
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Other V8 things - some of which float
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Other V6 things - none of which float
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Oh yeah, and 1 "Straight-Six" ...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


If a man says something in the garage - and his wife can't hear him - is he still wrong !!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Vintage 68 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome