950 Commander Upgraded to HP! - Team Camaro Tech
EFI in your modern Classic EFI conversions in early Camaros

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Apr 7th, 11, 07:51 PM Thread Starter
Senior Tech
Tim
 
Join Date: Mar 2001
Location: Florida
Posts: 182
950 Commander Upgraded to HP!

Spent 5 hours upgrading my previously 950 Commander MPFI SBC kit to HP specs...at least an hour of that was spend replanning some wire runs.

Fired on the first try and ran better than it had in years (attributable to how far my 'tuned' fuel maps were).

After a bit of confusion, my electric fan now works as advertised (one of the original reasons for the upgrade-don't ask...)

The nitrous trigger looks most promising too-that should really make this a fun ride that I've had for 25 years. I've already got the 48 pound injectors on order...

Tim

1969 Nova SS 350
EFI 407/TKO600/4.11
11.43 at 121 MPH

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
L48M20 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Apr 10th, 11, 05:12 AM Thread Starter
Senior Tech
Tim
 
Join Date: Mar 2001
Location: Florida
Posts: 182
Re: 950 Commander Upgraded to HP!

I've also deduced that I have a mechanical problem that causes misfires at idle and an inability to run lean at cruise (wants > 14.0 AFR). I've decided the cylinder heads are the culprit.

Hopefully this week a new set of AFR 220 Eliminators will be on their way...

First the electric fan wouldn't work on the 950 Commander...so I installed a complete HP updgrade.

Then the valve sealing was poor on my current AFR's...so I ordered a new set of Eliminators...this is fun and expensive!

:-)

Has anyone used the HP for the nitrous trigger (dry type)? The 48 pound injectors are enroute according to Summit (to replace the current 36's).

1969 Nova SS 350
EFI 407/TKO600/4.11
11.43 at 121 MPH

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
L48M20 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome