ez fast - Team Camaro Tech
EFI in your modern Classic EFI conversions in early Camaros

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old Jan 15th, 15, 07:10 PM Thread Starter
Senior Tech
Chris
 
Join Date: Jul 2009
Location: north carolina
Posts: 121
ez fast

hey guys...been off the site for a while i have an ezfast efi on a 383, with a tko600 and 373's. i have a flat spot in the 2500 rpm range part or full throttle no problem before that or after that...and have been unable to figure it out. does anyone know of other folks have had similar problems with this efi, its the orig one so im guessing 1.0. its been timed correctly..and i have the mds adjustable distributor that i have played with also, all to no avail. parked the car because its getting on my nerves. ready to pull it out and try a carb again.
ejs4732 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old Jan 15th, 15, 07:21 PM
Moderator
John
 
Vega$69's Avatar
 
Join Date: Sep 2010
Location: Vegas NV/Wesley Chapel FL
Posts: 13,323
Garage
Re: ez fast

Quote:
Originally Posted by ejs4732 View Post
hey guys...been off the site for a while i have an ezfast efi on a 383, with a tko600 and 373's. i have a flat spot in the 2500 rpm range part or full throttle no problem before that or after that...and have been unable to figure it out. does anyone know of other folks have had similar problems with this efi, its the orig one so im guessing 1.0. its been timed correctly..and i have the mds adjustable distributor that i have played with also, all to no avail. parked the car because its getting on my nerves. ready to pull it out and try a carb again.
Have you talked to Fast?

2017 Corvette ZO6 with ZO7 Option
66 Chevelle Protour LS3/525(SOLD AT Mecum 2018)
69 SS396 Cortez Silver(SOLD)
69 Z28(Sold)
69 Pro Tour - LS3/T56
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(SOLD)
69 Pro Tour - LS7/T56 (SOLD)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

69 Z28/RS Tribute355/5 Speed (SOLD)
69 RS Clone 427/TH400 (SOLD)
67 RSZZ502/5 Speed (SOLD)
69 Camaro 406 SBC/TH400 (SOLD)
Vega$69 is offline  
post #3 of 8 (permalink) Old Jan 15th, 15, 08:01 PM Thread Starter
Senior Tech
Chris
 
Join Date: Jul 2009
Location: north carolina
Posts: 121
Re: ez fast

not yet...thats my next stop...i got so frustrated that i parked the car..winter helps with that a bit, but i want it fixed before spring gets here..fairly soon in NC
ejs4732 is offline  
 
post #4 of 8 (permalink) Old Jan 15th, 15, 08:39 PM
Senior Tech
Mark
 
Join Date: Feb 2005
Location: Georgetown, TX
Posts: 335
Garage
Re: ez fast

I'd give the FAST tech support guys a call. I had a few issues with my 2.0 system, and they were pretty helpful.

69 RS, Hugger orange/black, Deluxe interior, Sony AM/FM/XM/CD, PS & PB. 355, forged pistons, Eagle rods, balanced, Iron Eagles, 9.4:1 CR, .038 quench, XR270HR Cam, Z28 intake, FAST-EZ EFI 2.0, Thorley Tri-Ys, TCI 700R4, 2400 stall, 3.42 posi
LukeWarm is offline  
post #5 of 8 (permalink) Old Jan 17th, 15, 04:49 PM Thread Starter
Senior Tech
Chris
 
Join Date: Jul 2009
Location: north carolina
Posts: 121
Re: ez fast

thanks guys, thats the plan...im outta ideas
ejs4732 is offline  
post #6 of 8 (permalink) Old Jan 19th, 15, 05:31 PM
Gold Lifetime Member
Bill
 
Join Date: Nov 2012
Location: North Texas
Posts: 39
Re: ez fast

check your grounds. frame to body , frame to engine they are as important as grounding the FAST properly.
Long Island Mouse is offline  
post #7 of 8 (permalink) Old Jan 24th, 15, 04:52 AM Thread Starter
Senior Tech
Chris
 
Join Date: Jul 2009
Location: north carolina
Posts: 121
Re: ez fast

thanks, i will.
ejs4732 is offline  
post #8 of 8 (permalink) Old Jan 27th, 15, 09:20 PM
Gold Lifetime Member
Steve
 
foreverlookin's Avatar
 
Join Date: Oct 2002
Location: Pflugerville, Texas
Posts: 1,761
Garage
Re: ez fast

I had a similar issue at about 2300 RPM and talking top them ruling out cam as it was below its threshold they suggested backing off on the rockers half turn....re-adjusted them and bog disappeared.

Steve
The best laid plans are those not made (mine)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
foreverlookin is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome