Help! Ram Jet 502 problem - Team Camaro Tech
EFI in your modern Classic EFI conversions in early Camaros

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old May 18th, 15, 10:48 AM Thread Starter
Senior Tech
Jason
 
Join Date: Apr 2010
Location: Brandon, Mississippi
Posts: 626
Help! Ram Jet 502 problem

just fired up my Ram Jet 502 for the first time yesterday. It will not come off of 3000 rpms. It's in the break in period, and when the DTC switch is off, it revs to 3k, when you switch it on, it drops down to 1500-1800 rpms. No vacuum leaks, is it in the tune? TPS not reading correctly?

1967 Camaro Yenko Pro Touring Tribute (being built)


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Follow my build
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
67YenkoJC is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old May 18th, 15, 07:15 PM
Tech Team
Brian
 
Join Date: Dec 2010
Location: North Carolina
Posts: 92
Re: Help! Ram Jet 502 problem

Had a similar problem with my Terminator setup. I had the target idle set too low to start with so it revved up to about 2500rpm. I had to increase my target idle a bit, adjust the throttle plates down a bit, conduct TPS reset, then restart and adjust from there. It took a few cycles but settled down nicely and only took a few minutes from start to finish. Hopefully this will help a little. Good luck!!

69 Camaro X44
408ci
Terminator EFI
AFR 195's
XE274H
T56 Magnum
4:10 posi
12 Bolt



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bkerns925 is offline  
post #3 of 3 (permalink) Old May 20th, 15, 05:20 PM Thread Starter
Senior Tech
Jason
 
Join Date: Apr 2010
Location: Brandon, Mississippi
Posts: 626
Re: Help! Ram Jet 502 problem

Found the problem, vacuum leak. Runs good.

1967 Camaro Yenko Pro Touring Tribute (being built)


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Follow my build
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
67YenkoJC is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome