Team Camaro Tech banner

cooling

  1. Engine
    Hey guys, I've got some hoses that need changing due to age and leaking. I can't seem to find any that fit at my local auto part store, but I remember seeing some universal ones on a couple cars here and there. They may work for the upper but what about the lower? The current lower I have has a...
  2. Heating & Cooling
    I am looking to change my fan to electric. Tired of the existing fan rubbing the shroud plus just want to clean up the look of the engine compartment. I am going to retain the OE radiator. looking for proven advice for which puller fan to use (size, brand, cfm, etc) plus where to get a shroud...
  3. Heating & Cooling
    Help!!! Replaced entire cooling system & still having cooling problems Hey Everyone! I am at the point where i almost just want to sell this damn thing and start over! I have a 68' RS with a 350 engine. Nothing major has been done to the engine and it runs pretty close to stock. I have been...
  4. Heating & Cooling
    I’ve searched the forums here multiple times looking for some direction, have tried a few minor adjustments but not getting fantastic results so I thought I’d ask for thoughts. Here’s the setup: 1968 Camaro SS, 502 GM Crate motor, TH 400 Trans. Aluminum short-style water pump, Power...
  5. Heating & Cooling
    I have a 68 with a 96 lt1 with the oil cooler. I am having problems finding a quality radiator that matches the 2 supply and 2 return line configuration required by the lt1 that will fit the 68's 21x17" core support. any suggestions? It seems that In addition to the standard supply and...
  6. Camaro Tech
    I just bought a 1968 Camaro RS with a 350 engine. When I bought it I was told that it has issues with overheating on warm days. I believe the radiator id copper and I'm running the six blade mechanical fan with a shroud. I want to increase the airflow, even at highway speeds, with minimal...
  7. Heating & Cooling
    I have a 69 camaro and the fan only blow's low in all positions on selector switch. I have installed a new resistor at the blower box and even installed new switches. I still have the same problem. Is there any other resistor that could be causing the problem.If any one has any ideas your help...
Top