Team Camaro Tech banner
1 - 11 of 11 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
good afternoon all,
I have a 1968 250 6 cylinder 2 speed transmission. when I put it in gear, sometimes it seems to pause, then go..... like it might be slipping or something. It does click into gear, so I know it is engaged. Any ideas I could look into?

thank you,
Wheel Tire Car Vehicle Hood
 

·
Registered
Joined
·
4,959 Posts
They don't call them "slip and slide Powerglide" transmissions for nothing! Looks like it's time to adjust the "band", but that usually means taking it to a transmission shop. It could also be something as simple as a leaky vacuum line going to the transmission modulator valve. That's what I'd check first since it's easy to find.

Ed
 

·
Premium Member
Joined
·
5,468 Posts
As Al said check the fluid. If it's low on fluid, or the papers or frictions on the clutches are worn, it will cause a slip like function. The band primarily slows down the drum for smoother shifts between first and second gear. It sounds like a hydraulic issue one way or the other to me. Could be as simple as low fluid or a partial clog on the filter screen. Or even a converter going bad.
 

·
Super Moderator
Joined
·
33,704 Posts
Trans oil level is low as the oil leaks through the oil pump from torque converter into the case and comes out the trans vent.
Run the Camaro every week for prevention
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
Hi all,
I thought I should check the fluid first, not sure why I didn't do that, I do know better.... just a senior moment I guess. The dip stick was dry, so I'll go get some transmission fluid. What king is recomended by you pros? Dextron? I think that is what I remember????
 

·
Premium Member
Joined
·
5,468 Posts
It used to be called Dextron 2. It's hard to find these days. Now it's generally called multi vehicle fluid.
 
1 - 11 of 11 Posts
Top