Team Camaro Tech banner

1 - 7 of 7 Posts

·
Registered
Joined
·
181 Posts
Discussion Starter #1
Hello,
I can't see to find the source problem of my GEN warning light. I have had the alternator tested, replaced the regulator, and made new connections and splices for the wiring involved in the system. The only thing that I have not checked is the under-dash connection. I have not taken the time to trace the wire coming off of the regulator yet. Any suggestions or things that I have not done?

The only changes that I made between last week and this week was added headers. I had to disconnect the starter and take out the power steering gear box to get them in. The car is a 1968 BB convert.
Thanks for the help
Rick
 

·
Registered
Joined
·
181 Posts
Discussion Starter #3
I am going to recheck the starter wires tomorrow. Thanks for the feedback.
Rick
 

·
Registered
Joined
·
181 Posts
Discussion Starter #4
I made new connections to the starter today and made sure that all the correct wires were hooked up and I charged the battery to capacity overnight, the GEN light is still on. I have had the alternator tested, put in a new regulator, made sure that I have good connections to the starter and made sure that any splices in the lines are new and tight. I can't think of anything else to do other than to buy a new alternator. Maybe the guy who tested it was high on something. Any other suggestions??
Rick
 

·
Moderator
Joined
·
10,144 Posts
Make shure you have juice at the alternator bat connector, red wire. You should have juice all the time, even with engine off.

If the alternator has some miles on it the brushes could be worn out and maybe it tested ok but could flake out on the car. I have even seen the brushes turn sideways when the brush holder wears.
You can full field the alternator by poking a small screwdriver into the back of the Alternator. With the terminal plug at 12 o'clock position, look at the two or three o'clock position for the hole.You have to find a D shaped hole about 5/16".

You will see a metal tang just thru the hole. you need to short the tang to the alternator case with the engine at 800 to 1000 rpm. Then have someone look at the light while you make the connection. This bypasses the voltage regulator, and makes the alternator put out full amps.
If the light goes out, you have a wiring problem, or voltage regulator problem. If the light stays on you have a bad alternator.

[This message has been edited by davidpozzi (edited 03-08-2000).]
 

·
Registered
Joined
·
575 Posts
Dave Is the test you describe for an altenator with internal regulator?
The 68 has an extetrnal regulator, if you want to bypass the regulator, disconnect the plug, there are two wires that have to be jumped, (Don't know which ones right now), any ways the Gen light wiring is some what of a strange bird.
When the key is turned on, not running the light comes on, power is fed from the swithch through the light and then to the altenator, the circuit is grounded internal of the altenator, when the engines starts and the altenator starts to produce current, power is then reversed through the circuit. since you have a positive 12 volts on both sides of the light and no ground the light then goes out.
Test your altenator, hook up a volt meter at the battery start the engine the voltage should rise to about 13 -14 volts, if it does not then the altenator or regulator is at fault, Try this test first and if you need more info place another post i can outline the full test procedures as it is quite extensive.
 
1 - 7 of 7 Posts
Top