Team Camaro Tech banner

1 - 2 of 2 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
I'm sure I'm not the only one who's experienced a problem with a 4th Gen (`95) Automatic Shifter getting stuck in the park position. Just wondering if anyone knows what the root cause and solution for this is? I've had the console apart in the past, and lubed all mechanical linkages below with GM Super Lube, and this seems to help for a while, but it will eventually get worse - to the point where I have to use both hands (thumbs) to press the gear seletor button down to get it out of park. This does seem to be worse when the weather gets colder, but that might be my imagination. This condition is also not as bad after the car is warmed up, and has been driven all day.

Today, I finally broke the shift lever button (shattered that bad boy with my bare hands no less!) trying to get it out of park. Now I'm looking at replacing everything up top, but still can't see what exactly is binding up underneath that is causing this.

Any ideas or suggestions would be greatly appreciated!

Thanks,

Bigblox
 

·
Registered
Joined
·
995 Posts
There is a solenoid on the left side of the shifter. It is the park lock solenoid. It will move when the brake pedal is depressed.
Do you brake lights work when the problem happens
Can you hear a click noise in the console area when the shifter will work, is it any different when it doesn't?
I would try eliminating the solenoid from the shifter to see if that takes care of the problem. If it does, you need a new park lock solenoid.
 
1 - 2 of 2 Posts
Top