Team Camaro Tech banner
141 - 144 of 144 Posts

·
Registered
Joined
·
542 Posts
Discussion Starter · #141 · (Edited)
So update - and CRAP!

The replacement came in from POL yesterday. POL has had to source these boosters from a new manufacturer and there are a few differences.
The mounting plate places the booster lower than the previous version. That's an Issue but with a new plate or modified brackets it could be corrected - maybe.
The low pressure return port in the booster now has a 8M x 1.25 thread in it instead of the standard 5/16 x 24 thread every other booster has always had. That means I cant use the banjo 90 degree fitting and that puts the low pressure return line right into the header - I do see a fix for this one. This is a deal breaker I think.
Few other differences are the Line ports are closer together and the threaded brake line is MUCH longer...

POL is showing my pictures to the Tech manager but at the end of the day I expect to be returning it for a refund.

I have already called Hyratech and asked them a few questions. Once things are settles with POL I will just order one from them. SO I get to redo all my lines as this one sits closer to the fire wall.

It Just never ends!!!!!!!!!!

PS - just got a call at 6pm from the sales Manager. After looking at my pics they seem to think I need the Hydro-Boost Firewall Mounting Plate Hydro-boost Firewall Mounting Plate which will center the unit and once I get that I need to rotate the unit 180 degrees. They think that will fix the clearance issues I am having. I told them that the accumulator will hit the valve cover if I rotate it but they want me to try. So we will see how this goes. They are sending the parts and I will try. This really just is going on forever...
 

·
Registered
Joined
·
542 Posts
Discussion Starter · #142 ·
This will be my Last post on this till probably Next year.

Got the parts from POL - Big Surprise, when I flipped the unit over the accumulator hit just as i said it would... I have got an RMA from POL and all thats getting shipped back today.

Just got off the phone with Hydratech. I ordered my unit and there is a 3 to 4 month back-order on these units from them. So nothing to do now but wait I guess. Its Insane to think from start to finish this project will have taken over a year to complete. Thanks for all the help guys. Lets hope this final attempt works.

Cory C
 

·
Premium Member
1968 Camaro LS3 TH400
Joined
·
600 Posts
I was looking for good news, and this is what you bring?
I’m just yanking your chain!
Look at this as the opportunity to spend time with family. I know it sounds (something) , but that’s just the way it is….if you could beat it into submission, you would have done it, no doubt!
Let me know if I can help you bud!
Michael
 

·
Registered
Joined
·
542 Posts
Discussion Starter · #144 ·
Thanks Michael. I have other stuff to do on the car and work is kicking up a lot of OT lately. I will just tinker with other things and wait for the parts to come in.

Funny thing is I started this way back in February for the CTC (Crusing the Coast) event that starts next weekend. I worked this project hard untill the last trying to make the event. I will still be there but I will be riding in the back seat of my Dad's 64 Fury LOL. Maybe next year =)
 
141 - 144 of 144 Posts
Top