Team Camaro Tech banner

1 - 14 of 14 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
My 68 camaro blinker lights are mixed up. When I turn indicator to right they all blink as if hazards are on unless my lights r on then nothing happens. When I turn indicator to the left they work fine with or without light on. And hazards don't work at all. What do I need to do? Thanks
 

·
Premium Member
Joined
·
8,048 Posts
You have a bad ground somewhere.
 

·
Premium Member
Joined
·
1,092 Posts
X2 on grounds and relay.....also front turn signal housings can cause issues due to corrosion.... Remove the lens and try a direct ground wire to the socket the bulb goes in on the right front parking/turn signal light......

Do all the lights have the same brightness when flashes are on?

Happy New Year
 

·
Premium Member
Joined
·
1,092 Posts
....same brightness grnds should be good. bulb type sounds correct all flashing.....

I would try replacing the turn signal relay or switch it with the Hazzard for a quick check. If it is not a relay....I would go to the turn signal assembly and look for a bad contact or broken part. Someone may have tried to repair a non canceiling issuse without sucess?

Hope this helps....
 

·
Registered
Joined
·
1,424 Posts
Check the wiring to the signal lights in the front. On my 67 my signal housing has three wires with black being the ground. Check all the sockets in the back making sure the insides are not rusted. Go thru the side marker harness too checking bulbs.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
When signal left lights and signals work fine but when turn right nothing happens when lights r on and back left tail light blinks w rights when head lights off
 

·
Premium Member
Joined
·
5,383 Posts
My 68 camaro blinker lights are mixed up. When I turn indicator to right they all blink as if hazards are on unless my lights r on then nothing happens. When I turn indicator to the left they work fine with or without light on. And hazards don't work at all. What do I need to do? Thanks
Is the hazard switch in the on position?
What does it do when you step on the brakes?

The Hazard flasher is in a different spot from the T/S flasher be sure it's there and good.

I'll assume you've checked to be sure no light bulbs have a single "wart" on the bottom. The correct ones for T/S-running lights should have two.

Jeff
 

·
Retired
Joined
·
16,027 Posts
Go back over ALL your grounds. Behind instrument cluster, guages to ground, headlight switch to body, even dimmer switch on the floor board needs good ground as do the Battery to frame, frame to body straps, regulator on the radiator support, etc. Everywhere you can find a wire going to a fender, frame etc, pull it apart, clean it up, clean the mating surface too (wire brush) then use star washers to ensure a good ground. you will find it, but elec. gremlins are the worst but usually the easiest to fix once you find the bad one. Its like that lost jig saw puzzle piece under the sofa... you know its there. :)
 

·
Registered
Joined
·
1,057 Posts
My 68 camaro blinker lights are mixed up. When I turn indicator to right they all blink as if hazards are on unless my lights r on then nothing happens. When I turn indicator to the left they work fine with or without light on. And hazards don't work at all. What do I need to do? Thanks
Did you get the car this way? Was it ever working right? Did you make some modification and now its like this? What is the back story to this problem.
 
1 - 14 of 14 Posts
Top