Team Camaro Tech banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
i'm working on a 69 z28. it has the single piston calipers and i cannot get pedal pressure after bleeding. i started at rt rear and worked around. bench bled new master. have rear brakes but no front. can't seem to get fluid through front. think i may have bad master but not sure because of valves and distribution block are something i have not worked on before and think i may have missed something. any help would be greatly appreciated.
thanks,
 

·
Registered
Joined
·
7,488 Posts
This is a common malady. Incorrect intermediate rod can cause this problem. So can the metering, or hold of valve (round one under MC). Make sure the booster-to-pedal rod clevis is adjusted so it provides the necessary free play, and the booster-to-master cylinder rod is correct so it doesn't move the primary piston forward at rest, covering up the compensating port hole. The plunger on the back of the hold off valve needs to be depressed sometimes for the fronts to bleed. To eliminate the possibility of it being bad, put a temporary line in it's place. It's a "metering" or "hold-off" valve; its function is to block any fluid flow to the front calipers until the valve sees 30-40 psi, which opens the valve. (eliminates nose dive when braking). Bleeding by pumping the pedal should open it with no problem, but if you use a pressure bleeder that applies less than 30-40 psi, that isn't enough to open the valve and you have to manually depress the button at the rear of the valve. And sometimes they don't depress. Any air at all in that MC you put in will give you grief also.

The distrubution block has no valving in it at all, it just a has a pressure switch that lights up the warning lamp.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Sauron67MM, thanks for the very informative reply. i thought it would be the valve. the car i'm working on belongs to a friend of mine and his father in law took it apart. don't know why. i have not taken it back apart and not sure if it is rebuildable. i figure it has a calibrated spring and maybe some o rings. i am getting rear brakes at almost full pedal but they do hold the rear tires. have ordered a new one from rick's. that's the only place i have found one. thanks again.
 
1 - 5 of 5 Posts
Top