Team Camaro Tech banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3,934 Posts
Discussion Starter #1
As you can see by the PIC below, rather then using the Backup lens I’m running a DUAL RED lens cluster. I extended the wiring harness from the outer pod to the middle pod so that I have 4 tail lights rather then 2 – similar to a Vette or Ferrari. The only problem is that the Turn Signals flash TOO FAST – probably because of added resistance to the circuit with the extra bulb.

How could I slow the Flash Rate down? Change out a resister in the Flasher (which seems like a lot of trouble), find bulbs with less resistance (which I’ve tried but can’t find) or would a flasher from a Vette work? Any Ideas!

 

·
Registered
Joined
·
293 Posts
IIRC, I had a similar problem with fast flash when hooking a trailer up to an old pickup. I resolved it by installing a "heavy duty" flasher. Check out your local parts house and see what they have to offer.
 

·
Registered
Joined
·
5,277 Posts
There are also solid state flashers available which I *think* are insenative to load. But these flashers may wire up a bit differently. I haven't tried using one so I only offer it as an option to explore. Randy's suggestion will be plug and play.
 

·
Registered
Joined
·
5,277 Posts
If you've got a heavy duty flasher in there and it's still flashing too fast, something seems to be really wrong. Are you talking about a rapid flash like3 or 4 times a second, or is it just slightly faster than what you'd like it to be. If it's a rapid flash, it makes me wonder if you don't have a grounded circuit somewhere. Do all the lights flash as they're supposed to - front and rear?
 

·
Registered
Joined
·
153 Posts
I had a 73 Z28 when i was 18, I did the same thing with the tail lights, But had no problem with the flashers after i was done, Maybe try the cheapest way out and try a different flasher....Crash
 

·
Registered
Joined
·
3,934 Posts
Discussion Starter #7 (Edited)
The Heavy Duty CTC Flasher did slow the flashing rate to about one every 1/2 second compared to the normal approximate rate of one per second. I've checked the wiring thoroughly and all looks good. No doubt these are Thermo Bio-Metal controlled. I intend to pull a trailer which will probably add additional load to the circuit thereby increasing the rate even faster.

If I recall the the Brake Lights and Flashers use the same Circuit. If I can not solve the problem, attempting to run Functional Dual Red Tail array, I could always disconnect the Brake and Flashing circuit to the Middle Pod. but the effect I'm after would not be there; in which case, I would have 4 Tail Lights but the Brake and Flashers would work only on the 2 Outer Pods rather then across 4.

I will just have to look for another heavy Duty Flasher or perhaps a Digital Unit, maybe from a Volvo. Hope to find the solution this week end and get back to you.

Thanks for your Input: RON
 
1 - 7 of 7 Posts
Top