Team Camaro Tech banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 1986 Camaro and when io start my car i see a nice big gust of smoke. Its probably something simple, but i think it is that the valve seals are messed up, because the smoke goes away. I dont really know...Also this car was not treated well by the last owner. I have 1 or 2 other problems. My car sometimes takes a while starting, like its not turning over even after i set the choke. And its also
taking about 1 minute that it has to be warmed up in. Even in warm weather. If i dont warm it up the car stalls when i shift into gear. I think it might be the choke needing to be cleaned. Am i right? Maybe? What do you recomend i do?should i just try do figure it out myself? If not how much do think it will cost to fix said problems? i would appreciate help scince i just got into learning about cars and this my first car i have owned (im only 17) Oh yeah, its not a standard transmission.....which..i..dont..like....
Thanx
 

·
Registered
Joined
·
995 Posts
Easy deal, if the car shows no blowby(take PCV out of valvecover,check and see if lots of smoke comes out of breather,with engine running).If no or little smoke valve seals should fix it.(350$) at a shop. Does car have a fast idle when you first start it up?If not, it sounds like choke is'nt working, or adjusted improperly. Good luck!
 

·
Registered
Joined
·
715 Posts
Also a good idea while you are working on the carb to replace the vacuum lines and change the fuel filter. I had to convert my 85's from rivets to screws just to adjust the choke. they make a kit for this

------------------
68 RS, Ash Gold,pwr windows,Hounds tooth
 
1 - 3 of 3 Posts
Top