Team Camaro Tech banner

1 - 9 of 9 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
My 86 Camaro IROC-Z is giving me a load of trouble. It's always had a hard time starting...usually I have to pump the accelerator to get it started.

Now, in the cold weather, it's flooding every time I try to start it. I just gas-fouled a second set of plugs yesterday. It'll stall if I don't keep a little throttle on it for at least 15 minutes while it warms up. It runs rough until it warms up, at which point it seems OK, but this is a pain.

I changed my air filter, thinking it may have been choking off airflow, but it's still acting up. Thinking it may be the carb (Rochester Quadra-Jet w/feedback I think). My guess is that the floats are sticking open, or the fast (choke) idle may be improperly adjusted. Do you think an overhaul/rebuild would be in order?

Also, do I need to change all the plugs (those back ones are an aggravation) or do you think if I got the front 4 in the back ones would clean themselves off once the engine started firing?

And does anyone know if Rochester still makes parts? And if not, do any other companies have a carb that'll work with the ECM in the later-model cars?

Thanks for putting up with me.

Mark
 

·
Registered
Joined
·
206 Posts
I don't know as much about the "newer" quads.I will say that if it runs O.K. after it warms up then it most likely is not the floats,because these would stick,or drop, after the engine was warm also.Does the choke pull off after the engine is started?If you run the stock air cleaner,do you have the "warm air tube" (I forget what these are called)that runs from the exhaust manifold to the air cleaner,in place?This most likely would not be the entire problem,but might help.Just a couple of ideas.

------------------
67 RS RAGTOP # matching, 4X4 CHEVY TRUCK
 

·
Moderator
Joined
·
3,355 Posts
SQ,
There is a vacuum pull off that should open the choke about 1/4' as soon as the motor starts running. They fail pretty regularly and cause the problems you are having. One of the guys at the Harley shop next door to me just had the same problem with his 86 Camaro, it was the pull off. Like Drake mentioned, if it runs ok once it tis warmed up, it is probably not something internal.
Hope this helps,

------------------
Bill Koustenis
Advanced Automotive Machine
Waldorf Md
 

·
Registered
Joined
·
15 Posts
I had the same problem with an 85 V6 camaro. I had the same exact symptons. My cause was ESC control module. It is a computerized thing that my car would stall out until the car warmed up and after a period of time it would fry my cap, rotor, wires and plugs. Once I had it changed my car ran fine with new ignition components. This is just a guess.

------------------
---Speed Kills---
---Buy a Ford---
---Live Forever---
 

·
Registered
Joined
·
42 Posts
Discussion Starter #5
I appreciate the help. I do have the heat riser tube in place. I was missing that when I first got the car. I think the choke is opening but I haven't really taken a good look at it in a while. It may have just recently failed. Usually it does open a little bit when the engine starts, though.

I was going to take the carb in and get it overhauled tomorrow if I could. This would probably fix choke problems, wouldn't it? The thing's probably due for it anyway, the car has 144000 miles on it and I'm pretty sure that thing hasn't been touched since. My uncle's a mechanic and he thought getting a rebuild/overhaul might be a good idea at this time.

Also, I was screwing around with the fast (choke) idle setting on the carb too, trying to get it to idle better at startup. Maybe this was a mistake...would setting the fast-idle screw too low cause this severe kind of flooding in cold weather?

Thanks again. I'm still relatively new at all of this, and I'm learning hands-on, but I'm still pretty much relying on my Chilton Manual to see me through.


Mark
 

·
Registered
Joined
·
206 Posts
The high idle setting just opens or closes the throttle plate while the choke is "on".This will not actually richen or lean out your mixture,so that should not be the problem.You also might want to get a can of carb. cleaner and spray down all your choke linkage,while working the choke by hand ,just in case it is just sticking closed.Like I said I don't have as much expieriance with your year carb.,but when I worked in a shop years ago I would constantly be replacing the choke cap on quads.This is the spring that actually forces the choke to close when it is cold,and opens it up as the engine gets warmer.I don't even know if this pertains to your year carb.,but if you have one it's not that expensive of a part to replace,and your manual should cover it's replacement and re-setting if you want to try it your self.You gotta get your hands dirty,this is how everyone starts to learn!Just a couple more ideas.

------------------
67 RS RAGTOP # matching, 4X4 CHEVY TRUCK
 

·
Registered
Joined
·
42 Posts
Discussion Starter #7
Thanks for your help, but I called the place I took the carb to when I needed a throttle bushing. They said that they rebuild the choke and pull-off when they rebuild the carb, if it needs it. I've got the carb off the manifold and I'm taking it up there today.

I have another question, though. On the front of the carb, there's one hose that comes off of it and splits into a "Y". One end goes to the PCV valve on the head (which I carelessly snapped trying to remove hoses this morning) and the other is blocked by a small wooden plug.

I never gave any thought to the plug, but I was wondering if anyone has any ideas what that plug is supposed to connect to. There's a small plastic hose in my car that looks like it was snapped off at one time and it looks like it goes in that direction, but the wood plug was in there when I got it. I wonder if I should connect these? Or is it something else?

Carb number, if it helps:
17086004
2215 JMY

Thanks, I appreciate all your help.
Mark
 

·
Registered
Joined
·
206 Posts
Just offhand my GUESS would be your vapor canister.If your underhood vacume hose diagram is still intact,see if you can use it to figure it out.Other wise you should find a vacume diagram for your vehicle.good luck.

------------------
67 RS RAGTOP # matching, 4X4 CHEVY TRUCK
 

·
Registered
Joined
·
42 Posts
Discussion Starter #9
Makes sense, Drake. Seems like the line I was looking at, the thin plastic one, comes off the air pump and that may be where it goes to...don't know for sure, but I don't think my diagrams are intact. There may be some in my Chilton, I'll have to look.

Anyway, the carb's in the shop and I hope to change the plugs tomorrow. Bye for now everyone. Thanks.
 
1 - 9 of 9 Posts
Top