Team Camaro Tech banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have an 89 camaro that seems to accelerate on its own. This generally happens the first time I drive it each day. It ran great until I changed the radiator, oil pressure sensor, and temp switch. The car starts fine and then as i pull out and give it a little gas, the rpms go to about 2000 then I shift to 2nd and give it a little gas and the rpms jump to 4000 or higher. I have to shut the car off to keep from going higher. Once I get up to speed I can keep the rpms down by downshifting but then end up going faster. I really dont know where to look. Any help would be greatly appreciated.
 

·
Registered
Joined
·
219 Posts
Need more info please!
Engine=???

------------------
67 Camaro LS6 454/TH400/12bolt 3.73
1989 TransAm 5.7L WS6 W/all the options
 

·
Registered
Joined
·
176 Posts
temp switch or temp sensor?

------------------
Leo Paugh
MCC #017
www.clark.net/pub/chevelle/mcc.htm
the bitterness of poor quality remains, long after the sweetness of the low price is forgotten
 

·
Registered
Joined
·
94 Posts
throtle cable junk? motor mounts junk? other thing my boss has a 99 chevy truck and his floor boards its self once anwille. dealer said it him but wen it does it in nutral all by its self.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
thanks for responding - the engine is a 305 V8 5.0L with TBI carb and the part replaced was the temp sensor. I pulled the car back in and as far as I can tell all the lines are hooked back up the way they were before I started this little project.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Thanks for responding - The car is an 89 with an e series engine. 305 with a V8 5.0L with TBI for carb. It was the temp sensor that I replaced. I brought the car back in and checked all the lines and they appear to be connected as they were before I started this little project
 

·
Registered
Joined
·
20 Posts
I'll also have a 89 Camaro with the TBI. Have you Checked the TCC wires on the trany. We my car is cold it tries to go by it's self. Thats just a 3rd Gen Camaro thing. Also you said you car is a Iroc "Not" Irocs have the TPI not the TBI

------------------
Charles Taylor
89 Camaro RS
 
1 - 7 of 7 Posts
Top