Team Camaro Tech banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Someone please help!!!! I have an 89 camaro 305 throttle body with 5 speed. It will not start. If you pour little bit of gas into carb, it will fire right up. Other than that it just turns over and never catches. I've tried, (well, dad's tried) just about everything and still can't figure it out. Check engine light comes on so I bought the code reader and it says everything is okay. Please, anyone give me some suggestions. Thanks.

------------------
KIM
 

·
Registered
Joined
·
168 Posts
Greetings kimvian and welcome to the site.
From what you are describing, it sounds like you have one fuel injector or possibly both of them on the verge of dying. If not the injectors themselves, possibly their wiring harnesses. If you would like, I have some more information on this that I could e-mail you.

The Trickster!!!!!!!!!!!!!!!!!
 

·
Registered
Joined
·
33 Posts
Most likely a bad fuel pump. An outside chance the injectors aren't firing. A quick check of the injectors is to use a long screw driver or something similar. Put one end on an injector and the other to your ear while someone cranks the engine over. You should here it click if they are being pulsed by the computer.

There is no test port to check the fuel pressure on your engine. Some 3/8 fuel line, a 15lb gauge and some clamps will do the job. It might be easier and safer to check it at the filter. If you check it at the TBI unit, the pressure line is the bigger of the two. 9-13lb is the specs. If the pump turns out to be the trouble, change the filter too.
 

·
Registered
Joined
·
18 Posts
Check your fuel lines. If one of them is cracked it will be sucking air instead of fuel, especially check right up by the tank where there is rubber lines that connect to the steel lines. I have seen this problem in a few cars.
 

·
Registered
Joined
·
159 Posts
Fuel pump is in tank so it "shouldn't be sucking air" it pushes the fuel not pulls it.Take fuel filler cap off and listen while someone turns key to on.See if you can hear pump running.You only have 2 seconds to do this because that is all the time gm runs their pumps with the key on engine not running.Turn key to off and wait a few seconds to try it again if you think you didn't hear it the first time.
 
1 - 6 of 6 Posts
Top