Team Camaro Tech banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 94 v6, but i only get about 18 mpg. I changed the spark plugs, wires, and all three coil packs. What else should i do?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
Ok so I have found out is not the coil packs, plugs, or wires. My car gets up to 55 then it starts to shake and does not accelerate anymore until i give it more than half throttle. Only does this in over drive. Would a bad fuel injector, tires needing rotated or reweighted, or a bad connector cause this? If something else please let me know.
 

·
Registered
Joined
·
57 Posts
Ok so I have found out is not the coil packs, plugs, or wires. My car gets up to 55 then it starts to shake and does not accelerate anymore until i give it more than half throttle. Only does this in over drive. Would a bad fuel injector, tires needing rotated or reweighted, or a bad connector cause this? If something else please let me know.
sounds like the tranny..
 

·
Premium Member
Joined
·
9,357 Posts
crossed coli pack??tps bad??
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I know its not the transmission as i have taken it to a transmission shop. The coil packs are put on right and we made sure of that. How hard is it to change the TPS?
 

·
Registered
Joined
·
2,292 Posts
Ok so I have found out is not the coil packs, plugs, or wires. My car gets up to 55 then it starts to shake and does not accelerate anymore until i give it more than half throttle. Only does this in over drive. Would a bad fuel injector, tires needing rotated or reweighted, or a bad connector cause this? If something else please let me know.
For a test at 55mph steady state cruise in OD..lightly apply the brake pedal to disengage the lock up feature in the converter.If the shake goes away,have a chat with your tranny guy once more.
 
1 - 8 of 8 Posts
Top