Team Camaro Tech banner

381 - 400 of 429 Posts

·
Premium Member
Brett - Leander, Texas 1969 SS396
Joined
·
1,586 Posts
What Holley pump? I installed the 12-300 in my stock tank and it is very quiet. When I first turn the key, it primes, and I can barely hear that. Once the engine starts I hear nothing from the pump.
As far as the fans, I don't think you want them running full blast from the beginning. To me, efficient is having them run only enough and the quantity required to cool the engine.
Brett....
 

·
Registered
1968 Camaro Convertible 250 to a LS3 Engine Swap
Joined
·
450 Posts
Discussion Starter #382

·
Premium Member
Joined
·
4,566 Posts
As noted above a PWM controller gives you continuously variable fan speed and they only run as fast as needed. Huge reduction in fan noise. Same fan control as used in new cars. It does not affect fan efficiency in any way.

Check with Carl at Vaporworx regarding Walbro pumps with his fuel pump controller. One word of warning. Your pump may be loud because you have very little fuel in the tank. Do not run that pump dry. It will fail in very short order. Always keep a few gallons of fuel in the tank.

Don
 

·
Registered
1968 Camaro Convertible 250 to a LS3 Engine Swap
Joined
·
450 Posts
Discussion Starter #384 (Edited)
Thanks Don,

I’ll look into the PWM Controller. The tank was brand new so I did only have approx 4 gallons in there from filling it with a gas can. I have since went to the station and filled her up and does seem to be a little quieter?

As someone has mentioned everything I hear is so new to me after not driving the car for the last year and a half the I'm very focused on all the new sounds the car is making.
 

·
Premium Member
Joined
·
686 Posts
Happy, Happy, Joy, Joy!

Finally Fired the LS3 up for the first time, instantly started at first turn of the key :)

Here is a video of the first start:

.
I'm late to the party but congrats ! I'm jealous. Gotta get mine going soon....
 

·
Registered
1968 Camaro Convertible 250 to a LS3 Engine Swap
Joined
·
450 Posts
Discussion Starter #386
Thank,

Wish I had not had that dry spell of not making any progress on her, now that it’s drivable I have been working on nonstop to finish the little cosmetic details.
 

·
Registered
1968 Camaro Convertible 250 to a LS3 Engine Swap
Joined
·
450 Posts
Discussion Starter #387 (Edited)
Picked a nice day to take a vacation day off from work, a cool breeze and 80 degrees instead of 90 and humid here in SWF. Took the Camaro on a 80 mile ride to the only Sonic in the area and then back home. I changed when the dual fans activate coming on when temperature reaches 210 and the off when it gets down to 200. When cruisinto along at 50mph the temperature fluctuats between 192-198. The settings I had before pretty much had them constantly on and not going below 192.

 

·
Registered
1968 Camaro Convertible 250 to a LS3 Engine Swap
Joined
·
450 Posts
Discussion Starter #388 (Edited)

·
Premium Member
Joined
·
4,566 Posts
Where did you get those battery post connectors? They look good.

Don
 

·
Registered
1968 Camaro Convertible 250 to a LS3 Engine Swap
Joined
·
450 Posts

·
Premium Member
Joined
·
686 Posts

·
Registered
1968 Camaro Convertible 250 to a LS3 Engine Swap
Joined
·
450 Posts
Discussion Starter #397
Does any know what the idle should be set at? I have it set at 600, it stars up fine and seems ok except when at a traffic light an it turns green an I step on the gas It seem to bog down with no acceleration unless I let up on the gas and the flutter the padel a little and then it hooks and snaps my head back. Perhaps I need to open up the Terminator X software and make some adjustments but what adjustments I no not?

Does not happen everytime, and other this the car seems to running great.

.
 

·
Premium Member
Brett - Leander, Texas 1969 SS396
Joined
·
1,586 Posts
Sixty8, I wish I knew how to help. I have a new efi and mine seems to be good at Idle and take off, but I don't know how I got it there. I was told to manually open throttle with engine off and as soon as the secondary's start to open, look at the IAC%. It should be 13% or less. Also, I did screw the blades open a little more but always re-set the TPS. Hopefully someone will chime in. Do you have a tuner? A guy helping you?
Brett....
 

·
Premium Member
Joined
·
4,566 Posts
Does any know what the idle should be set at? I have it set at 600, it stars up fine and seems ok except when at a traffic light an it turns green an I step on the gas It seem to bog down with no acceleration unless I let up on the gas and the flutter the padel a little and then it hooks and snaps my head back. Perhaps I need to open up the Terminator X software and make some adjustments but what adjustments I no not?

Does not happen everytime, and other this the car seems to running great.

.
Sorry I can’t help but I don’t know alot about Holley tuning. There is a guy on pro-touring.com who is pretty good at Holley tuning. Andrewb70 is his username and he does remote tuning.

Don
 
381 - 400 of 429 Posts
Top