Team Camaro Tech banner

1 - 10 of 10 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
The past few days i've noticed my head lights were brighter,my fuel pump was louder,etc..So l look down at my gauge and it's showing 18volts! When I apply the brakes it goes down a little but as soon as I give it gas the volts go right back up to 18. Is that a sign of my alternator going out? Or is it something else????
 

·
Registered
Joined
·
43 Posts
Discussion Starter #3
Thanks paulm I appreciate the info!
 

·
Premium Member
Joined
·
22,122 Posts
Joe, I've been there and done that.

If your regulator is not grounded, it will charge wide open all the time, and mine put out 18 volts when that happened. Check your regulator grounding.
 

·
Registered
Joined
·
794 Posts
I had that happen as well...the internal regulator was bad, unfortunately it blew my MSD box and digital dash before I figured it out. Good new is everything was covered under warranty including the alternator.
 

·
Registered
Joined
·
3,765 Posts
Joe, you never mentioned if your alternator is internally or externally regulated. If external, then may be a ground like Jim said or the regulator itself. If internally, then again the regulator may be bad, but it's a little more involved to replace the regulator when internal. It's usually not worth the effort unless you have an alternator that you really want to keep and reuse.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #8
Thanks for the help everyone! It was the regulator :yes:
 

·
Registered
Joined
·
57 Posts
Class67 - I don't mean to step on this thread but I was wondering if there is anything that can be done to protect the msd ignition box? How long do you suspect the regulator was bad before it took out the MSD box?
 

·
Registered
Joined
·
794 Posts
Class67 - I don't mean to step on this thread but I was wondering if there is anything that can be done to protect the msd ignition box? How long do you suspect the regulator was bad before it took out the MSD box?
It happened real quick, it was just when I finshed the car and drove it about 50 miles, brand new alternator and all and it just spiked upwards of 18 volts a couple of times and that was all it took. thinking back, I probably should of shut it down right then but I was 20 miles from home hoping that I would make it. As far as protecting the MSD box...it is kind of hard as the box is wired directly to the battery. Also, I have a 50 amp Max fuse for the entire system and it blew right through that as well.
 
1 - 10 of 10 Posts
Top