Team Camaro Tech banner

1 - 11 of 11 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
In my 84 camaro I have a problem. I Can start it an everything but it seems the alternator is not charging the battery. The battery can hold a charge beucase we have to charge it everytime we want to start. And I am sure the alternator works beucase the car runs forever as long as you have gas. Could the alternator be working but just weak on generating electricity? When you use the headlights when driving they go dim and drain the batt.

------------------
1984 Z28 Camaro V8 350
- 650 cfm Edelbrock carb
 

·
Registered
Joined
·
73 Posts
I'd check your voltage regulator. Is the alternator light coming on at all? If so then it can be either the regulator or the alternator, get them both tested
 

·
Registered
Joined
·
288 Posts
EKG,

The first thing you need to do is get a volt meter on the battery to see how much if any charge you are getting.

If the lights are going dim as you say, a loose belt can cause this.

If you always need to boost it, you could have a drain on the batt or even a bad batt.

Larry
 

·
Registered
Joined
·
522 Posts
Have your battery checked. Just because it shows 12.5 volts does not mean that it has the capacity to crank the car. If your battary has a dead cell or two you could show 12.5 volts but only have 200 Cold Cranking Amps or less. This in a battary that I recomend should be at least 600 CCA for a V8. The reason the car starts after you charge the battary might be because the battary has a "surface charge". The charge will disapate after a very short time. If you charge it and leave it alone for a day or two it most likely will not start the car. Many of your local auto parts stores will test your battary and your alternator. I know at Checker Auto, we can test them either on the car or off, and we do this for free. I personally do three or four a night. We also test starters, for free of course. On the other hand I have seen some cars that all checks out fine, but if the car is not started for a few days the battery goes dead. 9 out of ten times the culprit turns out to be a faulty horn relay but that has been mostly on older cars. On an 84 it could also be a possability.

------------------
Tim
67 ss/rs, MODIFIED
visit my page!!
AOL-IM = sixtsevnss

[This message has been edited by sixtsevnssrs (edited 10-27-2000).]
 

·
Registered
Joined
·
22 Posts
Discussion Starter #5
My horn isnt hooked up tho. There is only one wire comming up the steering column. I am thinking of takeing the alt into a shop and having them test it. And not to sound dumb but where is the alt light. On the dash the lights I see are. Check engine, belts and choke. The belts and choke never come on The check engine is always on. The engine is fine. Could the alt be makeing it come on?

------------------
1984 Z28 Camaro V8 350
- 650 cfm Edelbrock carb
 

·
Registered
Joined
·
22 Posts
Discussion Starter #6
O yeah there is breaks too. Thinking about it could he have wired it through the check engine soon light? And now its going on becase the alt is bad?

------------------
1984 Z28 Camaro V8 350
- 650 cfm Edelbrock carb
 

·
Registered
Joined
·
567 Posts
Some of the 3rd gens will not charge if the idiot light is burned out. Sounds stupid, but I had it happen to me. Also, on a 3rd gen, there is a small brown wire that goes from the fuse block, to the firewall connector and then to one of the relays on the drivers side firewall. This wire likes to bake itself and have the same effect.

------------------
------------------
Mark

1992 Firebird 355/Six Speed
1991 RS 350 / 700-R4
1987 Toyota Pickup 383 / 500 + HP 10.963 @ 119.95 Slicks / 11.997 @ 114.23 Radials
http://personal.lig.bellsouth.net/~racer383/
 

·
Registered
Joined
·
22 Posts
Discussion Starter #8
My girlfriends mom told me that if I start it up and unhook the bat cables. If it says running its not your alt its a short.

------------------
1984 Z28 Camaro V8 350
- 650 cfm Edelbrock carb
 

·
Registered
Joined
·
22 Posts
Discussion Starter #9
I removed the - on the bat and it kept going for like 2 sec and died
 

·
Registered
Joined
·
22 Posts
Discussion Starter #10
Ok heres how it goes

While started: reads 12v

Headlights on drops to like 11v

With heads and defrost it drops to 9v
when i turn them off it jumps back up
 

·
Registered
Joined
·
567 Posts
You don't ever want to pull the battery while the car is running. If the Alt is not bad, it will be if that is done to it. I swapped a bettery once, while the car was running. My bad. Burned up the regulator.



------------------
------------------
Mark

1992 Firebird 355/Six Speed
1991 RS 350 / 700-R4
1987 Toyota Pickup 383 / 500 + HP 10.963 @ 119.95 Slicks / 11.997 @ 114.23 Radials
http://personal.lig.bellsouth.net/~racer383/
 
1 - 11 of 11 Posts
Top