Team Camaro Tech banner

1 - 13 of 13 Posts

·
Registered
Joined
·
382 Posts
Discussion Starter #1
Hi Guys ...

I'm pretty much done with my '68 Camaro American Autowire Classic Update wiring installation ... but I've got one issue ...

The dash install part of this kit has a connector to plug into the horn relay ...

However, I thought that the '68 horn relay was under the hood, on the radiator support ...

Do I just run wiring to the under the hood horn relay to this IN-DASH horn relay connector? OR ... Am I missing something here ...

Thanks,
TIM
 

·
Registered
Joined
·
382 Posts
Discussion Starter #3
Its been awhile since I did my wire kit but I did not use the original horn relay with the update series it is built into the harness under the dash.
Yes, there is a connector built into the connector under the dash ... but what does this connect to? My horn relay is located under the hood on the radiator support, correct ...

Do I run leads from the horn relay to this under the dash connector? or what am I'm not getting here?
 

·
Vendor
Joined
·
125 Posts
Hi Tim,

If you look at the 500662 instructions, page 2, item number 8, you will see that we have provided a later style horn relay inside of the car for you. You simply plug the horn relay that is supplied in the fuse bag into the dash harness, then run the green wire on the 500571 front light harness out to the horns and connect them as the instructions show on page 2 or page 4 (of the 500571 inst. set) depending on whether your car is a standard model or a RS model. This will complete your horn circuit.

Feel free to give us a call is you get stuck.
 

·
Registered
Joined
·
382 Posts
Discussion Starter #6
Thanks
 

·
Premium Member
Joined
·
1,677 Posts
:thumbsup: wow! now that's customer service~
 

·
Registered
Joined
·
382 Posts
Discussion Starter #8
Yea ... that was great ...

I'm really digging this kit thus far ... everything is top quality ... and it looks as if everything that I need is present ...
 

·
Registered
Joined
·
382 Posts
Discussion Starter #10
Cool ...

Thanks ...
 

·
Registered
Joined
·
1,396 Posts
I started using AAW when I restored my vert and used one of the factory fit RS wire harnesses and it was all plug and play.When I had to rewire the entire car while building my racer I purchased the update kit and only had to call them once with a question!Great customer service then too.Teresa I will send you a pic of both of mine!
 

·
Registered
Joined
·
382 Posts
Discussion Starter #13
It's all coming together now ... should have it complete soon ...

I'm ready to light 'em up!!!
 
1 - 13 of 13 Posts
Top