Team Camaro Tech banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Ok, while I'm on the subject, another problem I have been having is when I turn on the heater, the fan works for a while, and then stops for a while, then starts back up. On the 67's is there a relay that I need to look at, or do you think it is the switch??:thumbsup:
 

·
Registered
Joined
·
56 Posts
I know on the my 69 there is a resistor/relay on top of the inside heater box. The wires come from the heater control switch to the relay and then to the blower motor. It sounds like your relay may be going, mine doesn't work at all. Power goes in but not out, hense, no blower motor. I don't know if the 67 is different.
 

·
Premium Member
Joined
·
22,122 Posts
The resister block reduces the power, and therefore the speed, in the lower speeds only. In high, the resister is comp[letely bypassed, power comes straight from the switch.

It is only a resister, there is no relay in a non A/C firstgen.

There is a high speed blower relay in A/C cars.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
So does would this relay cause the cutting out of the fan as I described? My car is an ac car.
 

·
Premium Member
Joined
·
22,122 Posts
The relay is for high speed only.
A/c cars have the resister unit located on the A/c suitcase, under the hood. The relay is neathere there too. Find em and check and clean the connections.
 

·
Registered
Joined
·
116 Posts
I hade similar problem turned out to be the blower motor itself! What a pain to replace but after 35 years it was time to do it and be done with it! Could be relay as I replaced as well but didn't fix it untill I did the blower motor! Might as well do complete overhaul of heating system if ya can!
 

·
Registered
Joined
·
5,277 Posts
Tracy, you didn't say if this issue is happening only in high speed or all speeds. Good to know your car is an A/C car since that clarifies a detail.

If non-high speed settings are affected, then I'm thinking it's a motor issue also. The blower resistors are cooled by air passing over them from the blower itself. As with most things, the hotter they get the more resistance they create. If your motor is sapping out on you, it will take more current to flow the same amount of air. Eventually you end up with a snow-ball affect. The resistor gets hot, not enough current flows to keep the fan moving and your stuck.
 
1 - 7 of 7 Posts
Top