Team Camaro Tech banner

1 - 8 of 8 Posts

·
Registered
Joined
·
101 Posts
Discussion Starter #1
Hello What’s the deal with the ballast resister? I’m using the stock distributor from my 69 z28 with a pertronix module and msd coil. Should I be using a ballast resistor?
Thanks Dave
 

·
Registered
Joined
·
1,047 Posts
No, resistor only needed with points ... The resistor steps DOWN the voltage... Once you convert to any electronic setup, you need the full 12 volts
 

·
Registered
Joined
·
523 Posts
Agree as far as the module is concerned but I thought the coil still needed the ballast resistor. May want to double-check the module instructions though.
Sort of a split set-up where the distributor gets a full 12 volts but the coil voltage is still reduced. May want to check with the MSD tech reps.
http://www.msdignition.com/
 

·
Registered
Joined
·
5,277 Posts
It depends on the dwell of the ignition and the coil impeadance whether or not a ballast resistor is needed. John is right - consult the module's documentation. Just want to bring up the fact that a coil that is designed to run with a ballast resistor on a breaker point system may not require one on a solid state ignition.

-dnult
 

·
Registered
Joined
·
7,159 Posts
If I am not mistaken our first gen Camaros and other points chevys have a resistor wire, the orange wire that goes to the coil. Also witha pertronixs you might want to read the instructions. I believe they tell you to run a ballast resistor. My Camaro when it had points would keep over heating the coil. I had tried 4 or 5 used coils and a few new ones. I then installed a ballast resistor and problem solved. Double check those instructions. I think I read it in there when I installed my pertronix.

Joe
 

·
Registered
Joined
·
1,047 Posts
make sure your coil isn't being energized full time. For example, when you first go to start the car, raise the hood and feel the coil. If it is warm to touch, and the car has been sitting, the coils is staying energized and you need to recheck your hook-up.
 

·
Registered
Joined
·
101 Posts
Discussion Starter #8
Thanks for the good idea But no voltage with key off hence no heat. What I did have though was 12 volts on the coil side of the ballist resister with the key at the on position. After the car started it dropped to 9 volts.
Thanks again for all suggestions
 
1 - 8 of 8 Posts
Top