Team Camaro Tech banner

1 - 7 of 7 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1
I had no idea when I bought an aluminum water pump what a hassle it was going to be to get alternator brackets to work! The water pump combined with the Chevelle/Corvette BB manifold I'm using are going to pretty much force me back to a stock water pump or a March alternator bracket. Anyone have any ideas?
 

·
Registered
Joined
·
1,147 Posts
I used stock bracket with my Edelbrock aluminum pump and RPM Air Gap manifold. What is the problem with your setup?
 

·
Registered
Joined
·
86 Posts
Discussion Starter #4
Short water pump with Weind Action Plus pump. Mounting flange is about 0.25" thicker than the stock iron pump so it moves the lower mount for the upper bracket forward.

Second issue is the mounting hole on the intake...it's set back further than stock. I'm sure I can make up a bushing to handle that.
 

·
Registered
Joined
·
323 Posts
This ENTIRE procedure should be done when the unit's being built and still on the engine stand. I'm sure many smaller engine builders (I come under this heading) would only be too happy to set it up for anyone. The slight additional cost would be well worth the aggravation of trying this in the car later. We just delivered the one in the photo here (notice this also included a "motor-plate"), which by the way we were told by "March" pulleys that none of their parts would fit. As I said, there's nothing more aggravating than having a belt fly off. Sometimes they're not reusable. Thanks, Gary in N.Y.
P.S. This one in particular was a real challenge due to all the components including the power steering unit. We did manage to use the "short" water pump, I believe it was "Weiand". Also, on any belt that has "long" stretch, you will definetly need the "deep" groove alternator pulley. The one pictured here is the "Moroso", but was polished to match the others (March's). No belt issues at all at this time. You can see the "span" on the alternator belt is quite long on this unit.
 

·
Registered
Joined
·
86 Posts
Discussion Starter #7
Tks for all the input...It looks like maybe it just needs a little "fiddle" to get things aligned. I was reviewing the disassembly photos and it looks like I can get it set up.
 
1 - 7 of 7 Posts
Top