Team Camaro Tech banner

1 - 16 of 16 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi!

Please someone help me.
I have a Camaro 1994 (V6 3.4) with a lot of black smoke, and dust too.
The sparks plugs are black (I change two weeks ago) and I found gasoline mixed with oil.
The car is running rough.
First I did take out the catalytic converter.
I still have the same problem.
I will change the oil and the sparks plugs againg (Any suggestions for the sparks plugs?)
I will change the EGR valve
The air pump
The air temp sensor (it is melted)
The check valve.
There something else that I have to check?

Thank you guys

Flavio
 

·
Registered
Joined
·
2,182 Posts
I'm assuming it's TBI? Check to make sure the injector isn't leaking around the O-rings. It should spray a fine, conical shaped mist of gas. It should not leak or drip.

Mark
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
The Oxygem sensor it looks like fine. I have to put a new one anyway?
How can I check the air pump? To see if still working?
 

·
Registered
Joined
·
75 Posts
fsr, Is the service engine light on, if not it probably won't be a sensor problem. When you do get it corrected the oxygen sensor should be replaced because running rich is going to kill it.
 

·
Premium Member
Joined
·
2,118 Posts
It may sound silly but I have seen a lot of clogged intake air filters do that same simptom. Good luck...
 

·
Registered
Joined
·
15 Posts
Discussion Starter #10
But when I drive over 3500 rpm, it runs rough until 4000 rpm.
What could be?

Thank you Everbody!
 

·
Registered
Joined
·
15 Posts
Discussion Starter #11
Please HELP me!

It is flooded again. (I can't believe on that)
I didn't find any codes with the scanner.
What it is the correct fuel pressure? (40lbs)

Thanks for you help guys!!!!

FSR
 

·
Registered
Joined
·
288 Posts
If the fuel pressure is ok, and you said no codes, then check the coil to see if the spark is to weak to burn the fuel.

I think this car is MPI, so you may want to get a noid light and check all the injectors, because if the ground to any of them is grounded to engine ground, it will turn that injector full on. This is because the 12v is to all injectors, and the ECM pulses the injectors through the ground side, thus constant ground = full open inj. This happens a lot with TBI as the air filter assy can pinch the wires.

Few thoughts,
Larry
 

·
Registered
Joined
·
15 Posts
Discussion Starter #13
Thank You!!!
Here (Lansing - MI) is 5Fº Do you think this can be a problem too?
I appreciate your help.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #14
The pressure of the pump on side of Reg is 68psi and the fuel regulator is 32psi-41psi (Reg. Vacuum unpluged)

I don't know if this is right. Someone could tell me what's the right pressure?
Can I find just the fuel regulator to buy?
Or I have to buy the fuel injector rail from a dealer?

Thanks.
 
1 - 16 of 16 Posts
Top