Team Camaro Tech banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have an '89 rs with a 5.0 tbi.
my problem is with the fuse right next to the battery. There seems to be a short somewhere it blows immediately. The wire exiting the fuse is orange, I checked the orange wires at the fuse box, but none of them are grounded out. Does anyone know where this wire goes. My car will not start until i fix this.
 

·
Registered
Joined
·
12 Posts
i wish i could help. i took my w-harness apart we i took my engine out yesterday for an swap, so i cant trace wire. but i suggest you go down to your patrs store and buy a repair manual. get a haynes i think there better then a chilton. there alot easyer on the mind not as tecky.
 

·
Registered
Joined
·
168 Posts
(1)Does your car have a fuel pump located in the fuel tank? (2)is the fuse a 20 amp fuse? if your answer to both these questions is yes, the fuse is your fuel pump/ecm fuse. it is there to protect your ecm from surges. Once this fuse blows your fuel pump won't work and the car won't start. This information is from the '89 camaro service manual that the dealers use. You probably have a wire shorting at the fuel pump relay mounted on the engine compartment firewall on the drivers side. Check these wires to see if any are bare and touching. good luck!!!!!
 

·
Registered
Joined
·
997 Posts
That same orange wire goes to the oil pressure switch,above your oil filter(might be next to the distributor,though).If your valve covers have leaked the oil runs all over the wires,shorting them out.

------------------
68 z28 ,68 rs 327 ,73 454 vette, 2 goofy kids
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Thanks trickster, The insulation on the wires going to my relay pulled away by almost 2". I put a new connector in it.
Its as good as new again.
 
1 - 7 of 7 Posts
Top