Team Camaro Tech banner

1 - 6 of 6 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1
With the help of others, I got most of my electrical gremlins gone.

BUT......

Now a new one (Oh, Why NOT!)
I got the turn signals to all work.
I got the turn signals to work with the parking lights on.
I got the four way flashers to all work right
BUT....
When ever I use the BRAKE LIGHTS & TURN SIGNAL LIGHTS, the REAR lights quit.

Hit brake lights, both rear lights work.

Hit brake lights, activate the left turn signal, left turn signal works, RIGHT brake light quits, BUT, the RIGHT PARKING light is still lite.

Hit brake lights, activate the right turn signal, RIGHT turn signal works, LEFT brake light quits, BUT, the LEFT PARKING light is still lite.

Both front lights always operate correct.
Turn off (L-R) turn signal and both brake lights ok again.

What did I do?
Cleaned sockets.
Cleaned bulbs.
Switched bulbs.
Cleaned taillight housings (was gonna swap them with another media blasted housing set, decided to try sandpaper first & that helped big time, along with pliers/screwdriver to clean contacts).

Am I now down to a bad stop light switch or bad turn signal switch?
I'm gonna get a new brake lite switch (I hope!!)




------------------
KED67
1967 RS/SS 350 4-Speed Convertible
1968 6 Cyl & PG/Console for the Wife & Son
 

·
Premium Member
Joined
·
2,118 Posts
I have that same situation right now, but only with the right side signal. If I use the right hand signal the the left stop light quits working. Don't think your problem is the stop switch. I had the chance to use a spare turn signal switch from one of my friends parts car and all started to work properly again. I'm planning to purshase a new one soon. I don't wanna say thats your case cause that is an expensive part (around $40) for me to recomend but if you have a chance, check with a known good signal switch first. Good luck...
 

·
Registered
Joined
·
74 Posts
Discussion Starter #3
I had a strong suspision it was the turn signal switch.
Now I have no brake lights, but 4 ways!
Found out previous person who Wife let work on car soldered the front lite to wires....
It oes on & on.
Cross platform time.
Turnsignal switches. What cars are the same?

Nova
Chevelle
Big car
to what year?
I assume to 1968.

------------------
KED67
1967 RS/SS 350 4-Speed Convertible
1968 6 Cyl & PG/Console for the Wife & Son
 

·
Registered
Joined
·
74 Posts
Discussion Starter #4
It's the turn signal switch!
Found one, but, hate installing them.
The steering wheel has never been off.
TIPS??

------------------
KED67
1967 RS/SS 350 4-Speed Convertible
1968 6 Cyl & PG/Console for the Wife & Son
 

·
Premium Member
Joined
·
2,118 Posts
Just make sure you remember the parts positions or order of installation. You might have some problem removing the ring clip thats mounted in the steering wheel shaft but I removed it with a small & thin screwdriver. Also you need to remove all the underneath plastic covers and loosen the steering post from it's mounting base, then you will find some metal covers that hold the multiwire in place. Those can be removed with the small screwdriver also. Oh if your steering has never been removed, get a hold of a steering wheel puller. If I forgot any details, I'm sure somebody can give you other hints. Good luck.

[This message has been edited by ORENCH (edited 06-26-2001).]
 

·
Registered
Joined
·
74 Posts
Discussion Starter #6
You hit the answers I already knew.
Want to visit Sunny Southern California to help me J/K!!
Check out my other thread for some great news!
ThankSS!!

------------------
KED67
1967 RS/SS 350 4-Speed Convertible
1968 6 Cyl & PG/Console for the Wife & Son
 
1 - 6 of 6 Posts
Top